aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-22 13:20:07 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-24 14:09:11 +0200
commitcc501ab021b6db0df1601895ddcb2c8b4d4146fa (patch)
treebd0fb2ca23800510935875c50ac8ed0648bea69b /package/kernel
parent58d2bd88aefef1f3a37b401223fccae374af6c63 (diff)
downloadupstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.tar.gz
upstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.tar.bz2
upstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.zip
kernel: set WATCHDOG_CORE dependency in kmod-hwmon-sch5627
For many target we have added CONFIG_WATCHDOG_CORE=y to the target config due to the following error: Package kmod-hwmon-sch5627 is missing dependencies for the following libraries: watchdog.ko However, actually the proper way appears to be setting the dependency for the kmod-hwmon-sch5627 package, as the error message demands. Do this in this patch and remove the target config entries added due to this issue. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 0b9e9d8b13..a39a8910f0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -409,7 +409,9 @@ $(eval $(call KernelPackage,hwmon-pwmfan))
define KernelPackage/hwmon-sch5627
TITLE:=SMSC SCH5627 monitoring support
- KCONFIG:=CONFIG_SENSORS_SCH5627
+ KCONFIG:= \
+ CONFIG_SENSORS_SCH5627 \
+ CONFIG_WATCHDOG_CORE=y
FILES:= \
$(LINUX_DIR)/drivers/hwmon/sch5627.ko \
$(LINUX_DIR)/drivers/hwmon/sch56xx-common.ko