aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-22 13:20:07 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-24 14:09:11 +0200
commitcc501ab021b6db0df1601895ddcb2c8b4d4146fa (patch)
treebd0fb2ca23800510935875c50ac8ed0648bea69b
parent58d2bd88aefef1f3a37b401223fccae374af6c63 (diff)
downloadupstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.tar.gz
upstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.tar.bz2
upstream-cc501ab021b6db0df1601895ddcb2c8b4d4146fa.zip
kernel: set WATCHDOG_CORE dependency in kmod-hwmon-sch5627
For many target we have added CONFIG_WATCHDOG_CORE=y to the target config due to the following error: Package kmod-hwmon-sch5627 is missing dependencies for the following libraries: watchdog.ko However, actually the proper way appears to be setting the dependency for the kmod-hwmon-sch5627 package, as the error message demands. Do this in this patch and remove the target config entries added due to this issue. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/kernel/linux/modules/hwmon.mk4
-rw-r--r--target/linux/arc770/config-5.41
-rw-r--r--target/linux/armvirt/config-5.41
-rw-r--r--target/linux/ath79/config-5.41
-rw-r--r--target/linux/bcm63xx/config-5.41
-rw-r--r--target/linux/malta/config-5.41
-rw-r--r--target/linux/x86/geode/config-4.191
-rw-r--r--target/linux/x86/geode/config-5.41
-rw-r--r--target/linux/x86/legacy/config-4.191
-rw-r--r--target/linux/x86/legacy/config-5.41
10 files changed, 3 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 0b9e9d8b13..a39a8910f0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -409,7 +409,9 @@ $(eval $(call KernelPackage,hwmon-pwmfan))
define KernelPackage/hwmon-sch5627
TITLE:=SMSC SCH5627 monitoring support
- KCONFIG:=CONFIG_SENSORS_SCH5627
+ KCONFIG:= \
+ CONFIG_SENSORS_SCH5627 \
+ CONFIG_WATCHDOG_CORE=y
FILES:= \
$(LINUX_DIR)/drivers/hwmon/sch5627.ko \
$(LINUX_DIR)/drivers/hwmon/sch56xx-common.ko
diff --git a/target/linux/arc770/config-5.4 b/target/linux/arc770/config-5.4
index fcbad961fd..ce712b4c34 100644
--- a/target/linux/arc770/config-5.4
+++ b/target/linux/arc770/config-5.4
@@ -196,4 +196,3 @@ CONFIG_TIMER_PROBE=y
CONFIG_TREE_SRCU=y
CONFIG_UNINLINE_SPIN_UNLOCK=y
CONFIG_USB_SUPPORT=y
-CONFIG_WATCHDOG_CORE=y
diff --git a/target/linux/armvirt/config-5.4 b/target/linux/armvirt/config-5.4
index 0754831fe4..4842825a1e 100644
--- a/target/linux/armvirt/config-5.4
+++ b/target/linux/armvirt/config-5.4
@@ -237,5 +237,4 @@ CONFIG_VIRTIO_MMIO=y
CONFIG_VIRTIO_NET=y
CONFIG_VIRTIO_PCI=y
CONFIG_VIRTIO_PCI_LEGACY=y
-CONFIG_WATCHDOG_CORE=y
CONFIG_XPS=y
diff --git a/target/linux/ath79/config-5.4 b/target/linux/ath79/config-5.4
index 6ef32cfefa..0f5352a921 100644
--- a/target/linux/ath79/config-5.4
+++ b/target/linux/ath79/config-5.4
@@ -245,4 +245,3 @@ CONFIG_TICK_CPU_ACCOUNTING=y
CONFIG_TINY_SRCU=y
CONFIG_USB_SUPPORT=y
CONFIG_USE_OF=y
-CONFIG_WATCHDOG_CORE=y
diff --git a/target/linux/bcm63xx/config-5.4 b/target/linux/bcm63xx/config-5.4
index 6c2cbb4cc3..dd4d67224c 100644
--- a/target/linux/bcm63xx/config-5.4
+++ b/target/linux/bcm63xx/config-5.4
@@ -277,6 +277,5 @@ CONFIG_TINY_SRCU=y
CONFIG_USB_SUPPORT=y
CONFIG_USE_OF=y
CONFIG_VM_EVENT_COUNTERS=y
-CONFIG_WATCHDOG_CORE=y
CONFIG_WATCHDOG_NOWAYOUT=y
CONFIG_WEAK_ORDERING=y
diff --git a/target/linux/malta/config-5.4 b/target/linux/malta/config-5.4
index 2b678cead6..29566ee171 100644
--- a/target/linux/malta/config-5.4
+++ b/target/linux/malta/config-5.4
@@ -340,5 +340,4 @@ CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_VT_HW_CONSOLE_BINDING=y
CONFIG_VXFS_FS=y
-CONFIG_WATCHDOG_CORE=y
CONFIG_XPS=y
diff --git a/target/linux/x86/geode/config-4.19 b/target/linux/x86/geode/config-4.19
index 316111aa0e..651c369178 100644
--- a/target/linux/x86/geode/config-4.19
+++ b/target/linux/x86/geode/config-4.19
@@ -121,7 +121,6 @@ CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=64
CONFIG_VIA_RHINE=y
CONFIG_VIA_RHINE_MMIO=y
-CONFIG_WATCHDOG_CORE=y
# CONFIG_WDT is not set
# CONFIG_X86_ACPI_CPUFREQ is not set
# CONFIG_X86_AMD_PLATFORM_DEVICE is not set
diff --git a/target/linux/x86/geode/config-5.4 b/target/linux/x86/geode/config-5.4
index 316111aa0e..651c369178 100644
--- a/target/linux/x86/geode/config-5.4
+++ b/target/linux/x86/geode/config-5.4
@@ -121,7 +121,6 @@ CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=64
CONFIG_VIA_RHINE=y
CONFIG_VIA_RHINE_MMIO=y
-CONFIG_WATCHDOG_CORE=y
# CONFIG_WDT is not set
# CONFIG_X86_ACPI_CPUFREQ is not set
# CONFIG_X86_AMD_PLATFORM_DEVICE is not set
diff --git a/target/linux/x86/legacy/config-4.19 b/target/linux/x86/legacy/config-4.19
index c1cd353114..2e5199185a 100644
--- a/target/linux/x86/legacy/config-4.19
+++ b/target/linux/x86/legacy/config-4.19
@@ -206,7 +206,6 @@ CONFIG_USB_STORAGE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
# CONFIG_VGACON_SOFT_SCROLLBACK_PERSISTENT_ENABLE_BY_DEFAULT is not set
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=64
-CONFIG_WATCHDOG_CORE=y
# CONFIG_WDT is not set
CONFIG_X86_ACPI_CPUFREQ=y
# CONFIG_X86_ACPI_CPUFREQ_CPB is not set
diff --git a/target/linux/x86/legacy/config-5.4 b/target/linux/x86/legacy/config-5.4
index c1cd353114..2e5199185a 100644
--- a/target/linux/x86/legacy/config-5.4
+++ b/target/linux/x86/legacy/config-5.4
@@ -206,7 +206,6 @@ CONFIG_USB_STORAGE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
# CONFIG_VGACON_SOFT_SCROLLBACK_PERSISTENT_ENABLE_BY_DEFAULT is not set
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=64
-CONFIG_WATCHDOG_CORE=y
# CONFIG_WDT is not set
CONFIG_X86_ACPI_CPUFREQ=y
# CONFIG_X86_ACPI_CPUFREQ_CPB is not set