aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-30 12:27:09 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-14 21:16:20 +0200
commitc5356d10c0e67284ea2087fcbc619af5e9fc9e8f (patch)
tree4bdfddc81836f25c8950e735d98ac2129364ea21 /package/kernel
parent73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659 (diff)
downloadupstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.tar.gz
upstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.tar.bz2
upstream-c5356d10c0e67284ea2087fcbc619af5e9fc9e8f.zip
kirkwood: move mmc/sd features to modules
All devices are using nand images. Built-in MMC/SD modules are not needed anymore. Run tested: pogo v4 Reviewed-by: Sungbo Eo <mans0n@gorani.run> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2cd4765196..936a1327fd 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -391,6 +391,23 @@ endef
$(eval $(call KernelPackage,mmc))
+define KernelPackage/mvsdio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell MMC/SD/SDIO host driver
+ DEPENDS:=+kmod-mmc @TARGET_kirkwood
+ KCONFIG:= CONFIG_MMC_MVSDIO
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+ AUTOLOAD:=$(call AutoProbe,mvsdio,1)
+endef
+
+define KernelPackage/mvsdio/description
+ Kernel support for the Marvell SDIO host driver.
+endef
+
+$(eval $(call KernelPackage,mvsdio))
+
+
define KernelPackage/sdhci
SUBMENU:=$(OTHER_MENU)
TITLE:=Secure Digital Host Controller Interface support