aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorUwe Kleine-König <uwe@kleine-koenig.org>2022-11-12 16:06:52 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-27 15:43:08 +0100
commita907c203405b186d2436f24d0ac0bc19b6700852 (patch)
treea6e958ea6f96e97680151e857b2a70b7366e63a8 /package/kernel
parenta4af427d805243305e5a8c8effb37d67f938f47d (diff)
downloadupstream-a907c203405b186d2436f24d0ac0bc19b6700852.tar.gz
upstream-a907c203405b186d2436f24d0ac0bc19b6700852.tar.bz2
upstream-a907c203405b186d2436f24d0ac0bc19b6700852.zip
kernel: add kmod-hwmon-sht3x support
The driver supports the temperature and humidity sensors chips SHT3x and STS3x by Sensirion. Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org> (cherry picked from commit cec9cbef449daea6529fbda64777ff1b7ae4e499)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b75c741ba0..bef9f14302 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -474,6 +474,21 @@ endef
$(eval $(call KernelPackage,hwmon-sht21))
+define KernelPackage/hwmon-sht3x
+ TITLE:=Sensiron SHT3x and compat. monitoring support
+ KCONFIG:=CONFIG_SENSORS_SHT3x
+ FILES:=$(LINUX_DIR)/drivers/hwmon/sht3x.ko
+ AUTOLOAD:=$(call AutoProbe,sht3x)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-lib-crc8)
+endef
+
+define KernelPackage/hwmon-sht3x/description
+ Kernel module for Sensirion SHT3x temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht3x))
+
+
define KernelPackage/hwmon-tmp102
TITLE:=Texas Instruments TMP102 monitoring support
KCONFIG:=CONFIG_SENSORS_TMP102