aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b75c741ba0..bef9f14302 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -474,6 +474,21 @@ endef
$(eval $(call KernelPackage,hwmon-sht21))
+define KernelPackage/hwmon-sht3x
+ TITLE:=Sensiron SHT3x and compat. monitoring support
+ KCONFIG:=CONFIG_SENSORS_SHT3x
+ FILES:=$(LINUX_DIR)/drivers/hwmon/sht3x.ko
+ AUTOLOAD:=$(call AutoProbe,sht3x)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-lib-crc8)
+endef
+
+define KernelPackage/hwmon-sht3x/description
+ Kernel module for Sensirion SHT3x temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht3x))
+
+
define KernelPackage/hwmon-tmp102
TITLE:=Texas Instruments TMP102 monitoring support
KCONFIG:=CONFIG_SENSORS_TMP102