aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2017-11-02 17:44:02 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 14:41:37 +0100
commit342d748eaff65811a1b11b944a9c66630d338ebc (patch)
tree9db65febb54e7d48693cfdb11893a5aa2936d3d7 /package/kernel
parentea5d9f5f72e1b687064389cba63bc7e61cc450ea (diff)
downloadupstream-342d748eaff65811a1b11b944a9c66630d338ebc.tar.gz
upstream-342d748eaff65811a1b11b944a9c66630d338ebc.tar.bz2
upstream-342d748eaff65811a1b11b944a9c66630d338ebc.zip
netdevices.mk: add Sun Neptune 10Gbit Ethernet
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 564f005b8b..42b7a8e4ca 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -304,6 +304,22 @@ endef
$(eval $(call KernelPackage,r6040))
+define KernelPackage/niu
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Sun Neptune 10Gbit Ethernet support
+ DEPENDS:=@PCI_SUPPORT
+ KCONFIG:=CONFIG_NIU
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/sun/niu.ko
+ AUTOLOAD:=$(call AutoProbe,niu)
+endef
+
+define KernelPackage/niu/description
+ This enables support for cards based upon Sun's Neptune chipset.
+endef
+
+$(eval $(call KernelPackage,niu))
+
+
define KernelPackage/sis900
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=SiS 900 Ethernet support