aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-08-24 00:17:56 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 14:41:37 +0100
commitea5d9f5f72e1b687064389cba63bc7e61cc450ea (patch)
tree52954e12040956057ec1f41ffcfe8280c9c1f4b0 /package/kernel
parentf96085b35d8aa6d100429bd1e802b9a1bf1442a8 (diff)
downloadupstream-ea5d9f5f72e1b687064389cba63bc7e61cc450ea.tar.gz
upstream-ea5d9f5f72e1b687064389cba63bc7e61cc450ea.tar.bz2
upstream-ea5d9f5f72e1b687064389cba63bc7e61cc450ea.zip
kernel: tune e1000e module parameters
The default e1000e parameters (interrupt throttling rate, MSI/MSI-X mode) are optimized for desktop and server computers to optimize user-space execution (i.e. what's typically referred to as "useful" work). This assumption breaks on a router under load where most of the "useful" work actually takes place either in hardware interrupt handlers (IRQ) or at software IRQ (swirq) modes, so we try to reflect that by overriding these parameters with more appropriate values. Patch-by: Philip Prindeville <philipp@redfish-solutions.com> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netdevices.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 3add0fdb50..564f005b8b 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -488,6 +488,9 @@ define KernelPackage/e1000e
KCONFIG:=CONFIG_E1000E
FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/e1000e/e1000e.ko
AUTOLOAD:=$(call AutoProbe,e1000e)
+ MODPARAMS.e1000e:= \
+ IntMode=1 \
+ InterruptThrottleRate=4,4,4,4,4,4,4,4
endef
define KernelPackage/e1000e/description