aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-23 04:08:26 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-23 04:08:26 +0000
commit9d7068ebdc5b1d5ced97fc8bd9bdabe4d3d32a99 (patch)
treeef61f31df78882740f0938d991254052974b69d5 /package/kernel/modules/other.mk
parent5034b75865a98d32655a36b9dfb5d88b75352681 (diff)
downloadupstream-9d7068ebdc5b1d5ced97fc8bd9bdabe4d3d32a99.tar.gz
upstream-9d7068ebdc5b1d5ced97fc8bd9bdabe4d3d32a99.tar.bz2
upstream-9d7068ebdc5b1d5ced97fc8bd9bdabe4d3d32a99.zip
package/kernel: use macros for kmod-rfkill depends
SVN-Revision: 21102
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d00b6f78a6..aaa7bf008e 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -262,8 +262,7 @@ $(eval $(call KernelPackage,ssb))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid \
- +(TARGET_x86||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx):kmod-rfkill
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -283,6 +282,7 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUART \
CONFIG_BT_HIDP
$(call AddDepends/crc16)
+ $(call AddDepends/rfkill)
endef
define KernelPackage/bluetooth/2.4
@@ -854,7 +854,6 @@ $(eval $(call KernelPackage,textsearch))
define KernelPackage/rfkill
SUBMENU:=$(OTHER_MENU)
TITLE:=RF switch subsystem support
- DEPENDS:=@TARGET_x86||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx
KCONFIG:= \
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT=y \
@@ -869,6 +868,7 @@ else
$(LINUX_DIR)/net/rfkill/rfkill-input.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,20,rfkill rfkill-input)
endif
+ $(call SetDepends/rfkill)
endef
define KernelPackage/rfkill/description