aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-23 04:01:03 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-23 04:01:03 +0000
commit5034b75865a98d32655a36b9dfb5d88b75352681 (patch)
treed99919ac999a2207ab313d264ed171891a636c16 /package/kernel/modules/other.mk
parent3b9e0000ecdc5cc8992be825a986dd473007e53e (diff)
downloadupstream-5034b75865a98d32655a36b9dfb5d88b75352681.tar.gz
upstream-5034b75865a98d32655a36b9dfb5d88b75352681.tar.bz2
upstream-5034b75865a98d32655a36b9dfb5d88b75352681.zip
package/kernel: introduce a new file that will be sourced first and holding complex dependencies spread over multiple files, use it for kmod-crc16
SVN-Revision: 21101
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 97ce3d3b70..d00b6f78a6 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -65,6 +65,7 @@ define KernelPackage/crc16
KCONFIG:=CONFIG_CRC16
FILES:=$(LINUX_DIR)/lib/crc16.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,20,crc16,1)
+ $(call SetDepends/crc16)
endef
define KernelPackage/crc16/description
@@ -261,7 +262,7 @@ $(eval $(call KernelPackage,ssb))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-crc16 +kmod-usb-core +!TARGET_x86:kmod-hid \
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid \
+(TARGET_x86||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx):kmod-rfkill
KCONFIG:= \
CONFIG_BLUEZ \
@@ -281,6 +282,7 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUSB \
CONFIG_BT_HCIUART \
CONFIG_BT_HIDP
+ $(call AddDepends/crc16)
endef
define KernelPackage/bluetooth/2.4