aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>2021-05-02 11:25:46 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:11:38 +0200
commitf298d5b810118c02b340c5bb5c85e1ac11579677 (patch)
treeca38019a72b4cff90d3c761a49bcca79dbba0ca0 /package/kernel/linux
parentb1baa01f1463c7b2cf5d10f7a35ed5dff47f2ac6 (diff)
downloadupstream-f298d5b810118c02b340c5bb5c85e1ac11579677.tar.gz
upstream-f298d5b810118c02b340c5bb5c85e1ac11579677.tar.bz2
upstream-f298d5b810118c02b340c5bb5c85e1ac11579677.zip
kernel: crypto: drop kmod-crypto-wq
CONFIG_CRYPTO_WORKQUEUE was removed in upstream commit[1]. This symbol doesn't exist since kernel 5.3 and this package is empty. 1. [ crypto: cryptd - move kcrypto_wq into cryptd ] (https://github.com/torvalds/linux/commit/3e56e168638b3e7147902c3b7257a57ea573a30e) Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 2775239e52..edce712c56 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -986,16 +986,6 @@ endef
$(eval $(call KernelPackage,crypto-user))
-define KernelPackage/crypto-wq
- TITLE:=CryptoAPI work queue handling
- KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
- FILES:=$(LINUX_DIR)/crypto/crypto_wq.ko
- AUTOLOAD:=$(call AutoLoad,09,crypto_wq)
- $(call AddDepends/crypto)
-endef
-$(eval $(call KernelPackage,crypto-wq))
-
-
define KernelPackage/crypto-xts
TITLE:=XTS cipher CryptoAPI module
DEPENDS:=+kmod-crypto-gf128 +kmod-crypto-manager