aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-04-26 19:42:29 +0200
committerDavid Bauer <mail@david-bauer.net>2020-04-29 16:03:00 +0200
commit3f660249e668d25dec65af3b2259433ed17046c1 (patch)
tree7d0c2d08aa60820dde02adcd29f35a83af9eb70b /package/kernel/linux
parent35a8657a404a78a01a886a3f82f903ea345137e6 (diff)
downloadupstream-3f660249e668d25dec65af3b2259433ed17046c1.tar.gz
upstream-3f660249e668d25dec65af3b2259433ed17046c1.tar.bz2
upstream-3f660249e668d25dec65af3b2259433ed17046c1.zip
kernel: hwmon: add Analog Devices AD741x support
Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 159c0eac9a..0b9e9d8b13 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -29,6 +29,20 @@ define AddDepends/hwmon
DEPENDS:=+kmod-hwmon-core $(1)
endef
+define KernelPackage/hwmon-ad7418
+ TITLE:=AD741x monitoring support
+ KCONFIG:=CONFIG_SENSORS_AD7418
+ FILES:=$(LINUX_DIR)/drivers/hwmon/ad7418.ko
+ AUTOLOAD:=$(call AutoLoad,60,ad7418 ad7418)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ad7418/description
+ Kernel module for Analog Devices AD7416, AD7417 and AD7418 temperature monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-ad7418))
+
define KernelPackage/hwmon-ads1015
TITLE:=Texas Instruments ADS1015
KCONFIG:= CONFIG_SENSORS_ADS1015