aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 159c0eac9a..0b9e9d8b13 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -29,6 +29,20 @@ define AddDepends/hwmon
DEPENDS:=+kmod-hwmon-core $(1)
endef
+define KernelPackage/hwmon-ad7418
+ TITLE:=AD741x monitoring support
+ KCONFIG:=CONFIG_SENSORS_AD7418
+ FILES:=$(LINUX_DIR)/drivers/hwmon/ad7418.ko
+ AUTOLOAD:=$(call AutoLoad,60,ad7418 ad7418)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ad7418/description
+ Kernel module for Analog Devices AD7416, AD7417 and AD7418 temperature monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-ad7418))
+
define KernelPackage/hwmon-ads1015
TITLE:=Texas Instruments ADS1015
KCONFIG:= CONFIG_SENSORS_ADS1015