aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-12-23 14:36:45 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-12-26 10:08:08 +0800
commit1508841b4e8e5b3ac10e61ea0eef61bba4a62abc (patch)
tree95ecbeefc09d285e3d311d14dd0a15451ca7d9f5 /package/kernel/linux
parentd45b50389deccbeaf262af0a115a4b0a25255ecc (diff)
downloadupstream-1508841b4e8e5b3ac10e61ea0eef61bba4a62abc.tar.gz
upstream-1508841b4e8e5b3ac10e61ea0eef61bba4a62abc.tar.bz2
upstream-1508841b4e8e5b3ac10e61ea0eef61bba4a62abc.zip
kmod-tcp-hybla: new module for hybla congestion control algorithm
Just the module and no default sysctl conf file is provided Link: https://forum.openwrt.org/t/20-xx-tcp-hybla/83076 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netsupport.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index d287e46270..4e78ac5478 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -947,6 +947,24 @@ endef
$(eval $(call KernelPackage,tcp-bbr))
+define KernelPackage/tcp-hybla
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=TCP-Hybla congestion control algorithm
+ KCONFIG:=CONFIG_TCP_CONG_HYBLA
+ FILES:=$(LINUX_DIR)/net/ipv4/tcp_hybla.ko
+ AUTOLOAD:=$(call AutoProbe,tcp_hybla)
+endef
+
+define KernelPackage/tcp-hybla/description
+ TCP-Hybla is a sender-side only change that eliminates penalization of
+ long-RTT, large-bandwidth connections, like when satellite legs are
+ involved, especially when sharing a common bottleneck with normal
+ terrestrial connections.
+endef
+
+$(eval $(call KernelPackage,tcp-hybla))
+
+
define KernelPackage/ax25
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=AX25 support