aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorAnderson McKinley <coyoso@tuta.io>2021-05-19 23:38:21 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:10:30 +0200
commit0eca9699b1f9339077fd4454b78a7f342b6c1dd7 (patch)
treee96997383a79ab738ceffb5574f5bb3c143fc94a /package/kernel/linux
parent21d4b228d17cded207fde6fa84c8bef6854ce818 (diff)
downloadupstream-0eca9699b1f9339077fd4454b78a7f342b6c1dd7.tar.gz
upstream-0eca9699b1f9339077fd4454b78a7f342b6c1dd7.tar.bz2
upstream-0eca9699b1f9339077fd4454b78a7f342b6c1dd7.zip
kernel: add kmod-input-leds
Adds support for LEDs on input devices. Useful for example on x86 laptops- allows re-purposing num/caps/scroll lock LEDs. Signed-off-by: Anderson McKinley <coyoso@tuta.io>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/leds.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index fdd5280fe4..301d314b1d 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -159,3 +159,20 @@ define KernelPackage/leds-uleds/description
endef
$(eval $(call KernelPackage,leds-uleds))
+
+
+define KernelPackage/input-leds
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Input device LED support
+ DEPENDS:=+kmod-input-core
+ KCONFIG:=CONFIG_INPUT_LEDS
+ FILES:=$(LINUX_DIR)/drivers/input/input-leds.ko
+ AUTOLOAD:=$(call AutoLoad,50,input-leds,1)
+endef
+
+define KernelPackage/input-leds/description
+ Provides support for LEDs on input devices- for example,
+ keyboard num/caps/scroll lock.
+endef
+
+$(eval $(call KernelPackage,input-leds))