aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/leds.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/leds.mk')
-rw-r--r--package/kernel/linux/modules/leds.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index fdd5280fe4..301d314b1d 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -159,3 +159,20 @@ define KernelPackage/leds-uleds/description
endef
$(eval $(call KernelPackage,leds-uleds))
+
+
+define KernelPackage/input-leds
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Input device LED support
+ DEPENDS:=+kmod-input-core
+ KCONFIG:=CONFIG_INPUT_LEDS
+ FILES:=$(LINUX_DIR)/drivers/input/input-leds.ko
+ AUTOLOAD:=$(call AutoLoad,50,input-leds,1)
+endef
+
+define KernelPackage/input-leds/description
+ Provides support for LEDs on input devices- for example,
+ keyboard num/caps/scroll lock.
+endef
+
+$(eval $(call KernelPackage,input-leds))