aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-02-09 19:01:28 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-02-24 01:15:22 +0200
commitc22cde2ea13133a9c75522a03fde225ccfd2770d (patch)
tree5f1880c78a2bb177c3aa7bc6d3793e8755ac2a6c /package/kernel/linux/modules/video.mk
parent9f4a7de48aa2ba07ae117937f01c2a262dde423d (diff)
downloadupstream-c22cde2ea13133a9c75522a03fde225ccfd2770d.tar.gz
upstream-c22cde2ea13133a9c75522a03fde225ccfd2770d.tar.bz2
upstream-c22cde2ea13133a9c75522a03fde225ccfd2770d.zip
kernel: add kmod-fb-tft-ili9486
This module adds support for the ILI9486 LCD controller used in devices like the Waveshare 3.5" and 4" LCD displays designed for Raspberry Pi. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index ee58e97b34..f11431dc2d 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -205,6 +205,22 @@ endef
$(eval $(call KernelPackage,fb-tft))
+define KernelPackage/fb-tft-ili9486
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=FB driver for the ILI9486 LCD Controller
+ DEPENDS:=+kmod-fb-tft
+ KCONFIG:=CONFIG_FB_TFT_ILI9486
+ FILES:=$(LINUX_DIR)/drivers/staging/fbtft/fb_ili9486.ko
+ AUTOLOAD:=$(call AutoLoad,09,fb_ili9486)
+endef
+
+define KernelPackage/fb-tft-ili9486/description
+ FB driver for the ILI9486 LCD Controller
+endef
+
+$(eval $(call KernelPackage,fb-tft-ili9486))
+
+
define KernelPackage/drm
SUBMENU:=$(VIDEO_MENU)
TITLE:=Direct Rendering Manager (DRM) support