aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-02-09 18:31:48 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-02-24 01:15:22 +0200
commit9f4a7de48aa2ba07ae117937f01c2a262dde423d (patch)
treed6a4ac78219b7a455c4bb80cc454c463b3a2901f /package/kernel/linux/modules/video.mk
parent4b3d17b709a57ca47f0815a54d559cb2265c1060 (diff)
downloadupstream-9f4a7de48aa2ba07ae117937f01c2a262dde423d.tar.gz
upstream-9f4a7de48aa2ba07ae117937f01c2a262dde423d.tar.bz2
upstream-9f4a7de48aa2ba07ae117937f01c2a262dde423d.zip
kernel: add kmod-fb-tft
This module adds support for small TFT LCD display modules. While this module also exists in the 4.9 kernel, we are not going to support this kernel in the next major release, so don't make it available for 4.9. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index fcfd5dc596..ee58e97b34 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -183,6 +183,28 @@ endef
$(eval $(call KernelPackage,fb-sys-ram))
+define KernelPackage/fb-tft
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=Support for small TFT LCD display modules
+ DEPENDS:= \
+ @GPIO_SUPPORT @!LINUX_3_18 @!LINUX_4_9 +kmod-backlight \
+ +kmod-fb +kmod-fb-sys-fops +kmod-fb-sys-ram +kmod-spi-bitbang
+ KCONFIG:= \
+ CONFIG_FB_BACKLIGHT=y \
+ CONFIG_FB_DEFERRED_IO=y \
+ CONFIG_FB_TFT
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/fbtft/fbtft.ko
+ AUTOLOAD:=$(call AutoLoad,08,fbtft)
+endef
+
+define KernelPackage/fb-tft/description
+ Support for small TFT LCD display modules
+endef
+
+$(eval $(call KernelPackage,fb-tft))
+
+
define KernelPackage/drm
SUBMENU:=$(VIDEO_MENU)
TITLE:=Direct Rendering Manager (DRM) support