aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 22:57:29 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 19:40:03 +0100
commit228bb84744589efa38ebddd7a75bf97de6789aeb (patch)
tree0b9ed1ececdc0dda9b3c72885897b23cf6332b4f /package/kernel/linux/modules/block.mk
parent95c1fce821c37d5afcd84df92b58c5ae184f8bcd (diff)
downloadupstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.gz
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.bz2
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.zip
kernel: make kmod-ata-core selected by dependent modulesupstreamless-old-master
Currently kmod-ata-* will not get into images unless kmod-ata-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-ata-ahci - kmod-ata-ahci-mtk - kmod-ata-sunxi While at it, use AddDepends/ata for kmod-ata-pdc202xx-old. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 5530931db4..b870304ad4 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -38,7 +38,7 @@ $(eval $(call KernelPackage,ata-core))
define AddDepends/ata
SUBMENU:=$(BLOCK_MENU)
- DEPENDS+=kmod-ata-core $(1)
+ DEPENDS+=+kmod-ata-core $(1)
endef
@@ -117,14 +117,13 @@ $(eval $(call KernelPackage,ata-nvidia-sata))
define KernelPackage/ata-pdc202xx-old
- SUBMENU:=$(BLOCK_MENU)
TITLE:=Older Promise PATA controller support
- DEPENDS:=kmod-ata-core
KCONFIG:= \
CONFIG_ATA_SFF=y \
CONFIG_PATA_PDC_OLD
FILES:=$(LINUX_DIR)/drivers/ata/pata_pdc202xx_old.ko
AUTOLOAD:=$(call AutoLoad,41,pata_pdc202xx_old,1)
+ $(call AddDepends/ata)
endef
define KernelPackage/ata-pdc202xx-old/description