aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 22:57:29 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 19:40:03 +0100
commit228bb84744589efa38ebddd7a75bf97de6789aeb (patch)
tree0b9ed1ececdc0dda9b3c72885897b23cf6332b4f
parent95c1fce821c37d5afcd84df92b58c5ae184f8bcd (diff)
downloadupstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.gz
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.bz2
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.zip
kernel: make kmod-ata-core selected by dependent modulesupstreamless-old-master
Currently kmod-ata-* will not get into images unless kmod-ata-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-ata-ahci - kmod-ata-ahci-mtk - kmod-ata-sunxi While at it, use AddDepends/ata for kmod-ata-pdc202xx-old. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
-rw-r--r--package/kernel/linux/modules/block.mk5
-rw-r--r--target/linux/ipq806x/Makefile2
-rw-r--r--target/linux/mediatek/image/mt7622.mk6
-rw-r--r--target/linux/ramips/image/mt7621.mk41
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk22
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk4
-rw-r--r--target/linux/sunxi/profiles/00-default.mk1
7 files changed, 38 insertions, 43 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 5530931db4..b870304ad4 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -38,7 +38,7 @@ $(eval $(call KernelPackage,ata-core))
define AddDepends/ata
SUBMENU:=$(BLOCK_MENU)
- DEPENDS+=kmod-ata-core $(1)
+ DEPENDS+=+kmod-ata-core $(1)
endef
@@ -117,14 +117,13 @@ $(eval $(call KernelPackage,ata-nvidia-sata))
define KernelPackage/ata-pdc202xx-old
- SUBMENU:=$(BLOCK_MENU)
TITLE:=Older Promise PATA controller support
- DEPENDS:=kmod-ata-core
KCONFIG:= \
CONFIG_ATA_SFF=y \
CONFIG_PATA_PDC_OLD
FILES:=$(LINUX_DIR)/drivers/ata/pata_pdc202xx_old.ko
AUTOLOAD:=$(call AutoLoad,41,pata_pdc202xx_old,1)
+ $(call AddDepends/ata)
endef
define KernelPackage/ata-pdc202xx-old/description
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 42f91371c3..93a90cc026 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -19,7 +19,7 @@ KERNELNAME:=zImage Image dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
- kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+ kmod-ata-ahci kmod-ata-ahci-platform \
kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-usb-phy-qcom-dwc3 kmod-usb3 kmod-usb-dwc3-qcom \
kmod-ath10k-ct wpad-basic \
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 486ab98b0f..0d8af5a9ee 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -3,8 +3,7 @@ define Device/mediatek_mt7622-rfb1
DEVICE_MODEL := MTK7622 rfb1 AP
DEVICE_DTS := mt7622-rfb1
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
- DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
- kmod-ata-core kmod-ata-ahci-mtk
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += mediatek_mt7622-rfb1
@@ -14,7 +13,6 @@ define Device/bpi_bananapi-r64
DEVICE_DTS := mt7622-bananapi-bpi-r64
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
SUPPORTED_DEVICES := bananapi,bpi-r64
- DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
- kmod-ata-core kmod-ata-ahci-mtk
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += bpi_bananapi-r64
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f24830bfb7..4fcd92cced 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -115,8 +115,8 @@ define Device/afoundry_ew1200
IMAGE_SIZE := 16064k
DEVICE_VENDOR := AFOUNDRY
DEVICE_MODEL := EW1200
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-mt7603 \
- kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-mt76x2 kmod-mt7603 kmod-usb3 \
+ kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += ew1200
endef
TARGET_DEVICES += afoundry_ew1200
@@ -125,8 +125,7 @@ define Device/alfa-network_quad-e4g
IMAGE_SIZE := 16064k
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := Quad-E4G
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3 \
- uboot-envtools
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3 uboot-envtools
endef
TARGET_DEVICES += alfa-network_quad-e4g
@@ -233,8 +232,8 @@ define Device/d-team_pbr-m1
IMAGE_SIZE := 16064k
DEVICE_VENDOR := PandoraBox
DEVICE_MODEL := PBR-M1
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-mt7603 kmod-mt76x2 \
- kmod-sdhci-mt7620 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-mt7603 kmod-mt76x2 kmod-sdhci-mt7620 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += pbr-m1
endef
TARGET_DEVICES += d-team_pbr-m1
@@ -316,7 +315,7 @@ TARGET_DEVICES += gehua_ghl-r-001
define Device/gnubee_gb-pc1
DEVICE_VENDOR := GnuBee
DEVICE_MODEL := Personal Cloud One
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
IMAGE_SIZE := 32448k
endef
TARGET_DEVICES += gnubee_gb-pc1
@@ -324,7 +323,7 @@ TARGET_DEVICES += gnubee_gb-pc1
define Device/gnubee_gb-pc2
DEVICE_VENDOR := GnuBee
DEVICE_MODEL := Personal Cloud Two
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
IMAGE_SIZE := 32448k
endef
TARGET_DEVICES += gnubee_gb-pc2
@@ -512,8 +511,8 @@ define Device/mqmaker_witi
IMAGE_SIZE := 16064k
DEVICE_VENDOR := MQmaker
DEVICE_MODEL := WiTi
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-mt76x2 \
- kmod-sdhci-mt7620 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-mt76x2 kmod-sdhci-mt7620 kmod-usb3 \
+ kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += witi mqmaker,witi-256m mqmaker,witi-512m
endef
TARGET_DEVICES += mqmaker_witi
@@ -805,7 +804,7 @@ define Device/unielec_u7621-06-16m
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
DEVICE_VARIANT := 16M
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
SUPPORTED_DEVICES += u7621-06-256M-16M unielec,u7621-06-256m-16m
endef
TARGET_DEVICES += unielec_u7621-06-16m
@@ -815,7 +814,7 @@ define Device/unielec_u7621-06-64m
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
DEVICE_VARIANT := 64M
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
SUPPORTED_DEVICES += unielec,u7621-06-512m-64m
endef
TARGET_DEVICES += unielec_u7621-06-64m
@@ -895,7 +894,7 @@ define Device/xiaoyu_xy-c5
IMAGE_SIZE := 32448k
DEVICE_VENDOR := XiaoYu
DEVICE_MODEL := XY-C5
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-usb3
endef
TARGET_DEVICES += xiaoyu_xy-c5
@@ -903,8 +902,8 @@ define Device/xzwifi_creativebox-v1
IMAGE_SIZE := 32448k
DEVICE_VENDOR := CreativeBox
DEVICE_MODEL := v1
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-mt7603 kmod-mt76x2 \
- kmod-sdhci-mt7620 kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-mt7603 kmod-mt76x2 kmod-sdhci-mt7620 \
+ kmod-usb3
endef
TARGET_DEVICES += xzwifi_creativebox-v1
@@ -949,8 +948,8 @@ define Device/zbtlink_zbt-wg2626
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG2626
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 \
- kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += zbt-wg2626
endef
TARGET_DEVICES += zbtlink_zbt-wg2626
@@ -960,8 +959,8 @@ define Device/zbtlink_zbt-wg3526-16m
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG3526
DEVICE_VARIANT := 16M
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 \
- kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += zbt-wg3526 zbt-wg3526-16M
endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
@@ -971,8 +970,8 @@ define Device/zbtlink_zbt-wg3526-32m
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG3526
DEVICE_VARIANT := 32M
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 \
- kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
SUPPORTED_DEVICES += ac1200pro zbt-wg3526-32M
endef
TARGET_DEVICES += zbtlink_zbt-wg3526-32m
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index cc67f4dd62..8fa648176f 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -9,7 +9,7 @@
define Device/cubietech_cubieboard2
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard2
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun7i-a20
endef
TARGET_DEVICES += cubietech_cubieboard2
@@ -17,7 +17,7 @@ TARGET_DEVICES += cubietech_cubieboard2
define Device/cubietech_cubietruck
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubietruck
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
SOC := sun7i-a20
endef
TARGET_DEVICES += cubietech_cubietruck
@@ -58,7 +58,7 @@ TARGET_DEVICES += lamobo_lamobo-r1
define Device/lemaker_bananapi
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi
- DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
SOC := sun7i-a20
endef
TARGET_DEVICES += lemaker_bananapi
@@ -66,7 +66,7 @@ TARGET_DEVICES += lemaker_bananapi
define Device/lemaker_bananapi-m2-ultra
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi M2 Ultra
- DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
SOC := sun8i-r40
endef
TARGET_DEVICES += lemaker_bananapi-m2-ultra
@@ -74,7 +74,7 @@ TARGET_DEVICES += lemaker_bananapi-m2-ultra
define Device/lemaker_bananapro
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pro
- DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-brcmfmac
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi kmod-brcmfmac
SOC := sun7i-a20
endef
TARGET_DEVICES += lemaker_bananapro
@@ -82,8 +82,8 @@ TARGET_DEVICES += lemaker_bananapro
define Device/linksprite_pcduino3
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino3
- DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi \
- kmod-rtl8xxxu rtl8188eu-firmware
+ DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-sunxi kmod-rtl8xxxu \
+ rtl8188eu-firmware
SOC := sun7i-a20
endef
TARGET_DEVICES += linksprite_pcduino3
@@ -99,7 +99,7 @@ TARGET_DEVICES += mele_m9
define Device/olimex_a20-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi
SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime
@@ -107,7 +107,7 @@ TARGET_DEVICES += olimex_a20-olinuxino-lime
define Device/olimex_a20-olinuxino-lime2
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME2
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime2
@@ -116,7 +116,7 @@ define Device/olimex_a20-olinuxino-lime2-emmc
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME2
DEVICE_VARIANT := eMMC
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
@@ -124,7 +124,7 @@ TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
define Device/olimex_a20-olinuxino-micro
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-MICRO
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun7i
endef
TARGET_DEVICES += olimex_a20-olinuxino-micro
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index de10d5d6cc..643b3d4b1e 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -9,7 +9,7 @@
define Device/cubietech_a10-cubieboard
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun4i
endef
TARGET_DEVICES += cubietech_a10-cubieboard
@@ -34,7 +34,7 @@ TARGET_DEVICES += marsboard_a10-marsboard
define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A10-OLinuXino-LIME
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun4i
endef
TARGET_DEVICES += olimex_a10-olinuxino-lime
diff --git a/target/linux/sunxi/profiles/00-default.mk b/target/linux/sunxi/profiles/00-default.mk
index 101769cf7b..cecdd0b837 100644
--- a/target/linux/sunxi/profiles/00-default.mk
+++ b/target/linux/sunxi/profiles/00-default.mk
@@ -8,7 +8,6 @@
define Profile/Default
NAME:=Default Profile (all drivers)
PACKAGES:= \
- kmod-ata-core \
kmod-ata-sunxi \
kmod-brcmfmac \
kmod-rtc-sunxi \