aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorSteven Lin <steven.lin@senao.com>2019-09-02 10:39:45 +0800
committerChristian Lamparter <chunkeey@gmail.com>2020-02-28 22:29:10 +0100
commita736d912e2bad6c470c73fbf47c45ec3017371af (patch)
tree6b4da25fb2d2f0d2c9fff5419b105f1d1402e641 /package/firmware
parent977c7f12deefc152b7d62de06f4973a54a71d746 (diff)
downloadupstream-a736d912e2bad6c470c73fbf47c45ec3017371af.tar.gz
upstream-a736d912e2bad6c470c73fbf47c45ec3017371af.tar.bz2
upstream-a736d912e2bad6c470c73fbf47c45ec3017371af.zip
ipq40xx: add support for EnGenius EAP2200
SOC: IPQ4019 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB FLASH: NOR 4 MiB + NAND 128 MiB ETH: Qualcomm Atheros QCA8072 WLAN1: Qualcomm Atheros QCA4019 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4019 5GHz 802.11a/n/ac 2:2x2 WLAN2: Qualcomm Atheros QCA9888 5GHz 802.11a/n/ac 2:2x2 INPUT: WPS Button LEDS: Power, LAN1, LAN2, WLAN 2.4GHz, WLAN 5GHz-1, WLAN 5GHz-2, OPMODE 1. Load Ramdisk via U-Boot To set up the flash memory environment, do the following: a. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters: * 115200bps * 8N1 b. Confirm that the PC is connected to the board using one of the Ethernet ports. c. Set a static ip 192.168.99.8 for Ethernet that connects to board. d. The PC must have a TFTP server launched and listening on the interface to which the board is connected. e. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown. U-BOOT> set serverip 192.168.99.9 && tftpboot 0x84000000 192.168.99.8:openwrt.itb && bootm Signed-off-by: Steven Lin <steven.lin@senao.com> [copied 4.19 dts to 5.4] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ipq-wifi/Makefile2
-rw-r--r--package/firmware/ipq-wifi/board-engenius_eap2200.qca4019bin0 -> 24324 bytes
-rw-r--r--package/firmware/ipq-wifi/board-engenius_eap2200.qca9888bin0 -> 12172 bytes
3 files changed, 2 insertions, 0 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 610dee18e0..fc1b10343e 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -28,6 +28,7 @@ ALLWIFIBOARDS:= \
aruba_ap-303 \
avm_fritzrepeater-1200 \
dlink_dap2610 \
+ engenius_eap2200 \
engenius_emd1 \
ezviz_cs-w3-wd1200g-eup \
linksys_ea8300 \
@@ -95,6 +96,7 @@ endef
$(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
$(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
$(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
+$(eval $(call generate-ipq-wifi-package,engenius_eap2200,EnGenius EAP2200))
$(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
$(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
diff --git a/package/firmware/ipq-wifi/board-engenius_eap2200.qca4019 b/package/firmware/ipq-wifi/board-engenius_eap2200.qca4019
new file mode 100644
index 0000000000..337d896d1e
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-engenius_eap2200.qca4019
Binary files differ
diff --git a/package/firmware/ipq-wifi/board-engenius_eap2200.qca9888 b/package/firmware/ipq-wifi/board-engenius_eap2200.qca9888
new file mode 100644
index 0000000000..2e938f4785
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-engenius_eap2200.qca9888
Binary files differ