aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-02-25 20:07:36 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-12 12:59:44 +0100
commit3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e (patch)
tree2b254548a57ea46d4065c0fc2818f75d23b086c2 /package/firmware
parent4ec2f33bfea560ecfa6b75e13abc515fe90d76a4 (diff)
downloadupstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.tar.gz
upstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.tar.bz2
upstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.zip
layerscape: resurrect support for FRDM-LS1012A
Re-add support for NXP FRDM-LS1012A, which mimics the flash layout of the rest boards supported by LSDK. 0x000000000000-0x000000100000 : "bl2" 0x000000100000-0x000000500000 : "fip" 0x000000500000-0x000000600000 : "u-boot-env" 0x000000600000-0x000000a00000 : "reserved-1" 0x000000a00000-0x000000d00000 : "pfe" 0x000000d00000-0x000000f00000 : "reserved-2" 0x000000f00000-0x000001000000 : "dtb" 0x000001000000-0x000002000000 : "kernel" 0x000002000000-0x000004000000 : "ubifs" Specification SoC: LS1012A single core 800MHz RAM: 512 MB DDR3 Flash: 64 MB QSPI NOR Ethernet: 2x 10/100/1000 Mbps Connectors: µUSB 3.0 OTG µUSB 2.0 (debugging & power input) 2x 3.5mm jack for microphone & headphone (SGTL5000) Arduino Shield expansion with I2C, SPI, UART, and GPIO JTAG LEDS: 3x (non-configurable) Buttons: 1x (reset, non-configurable) Be advised that erasing or writing 64MB flash takes some time to finish. Do not reset the board until all operations end with success, otherwise You'll need external tools to re-program the flash chip. Installation Follow the QSPI programing procedure for LS1012AFRWY board in target/linux/layerscape/README, point 3.3. Don't forget about updating U-Boot environment with MAC addresses of ethernet interfaces, variable 'ethaddr' for eth0 and 'eth1addr' for eth1. As the LSDK images do not support sysupgrade, nor do changes in this commit, it's planed in upcoming submissions. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/layerscape/ls-rcw/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/firmware/layerscape/ls-rcw/Makefile b/package/firmware/layerscape/ls-rcw/Makefile
index 5bcbff5bc4..ddef58fa0b 100644
--- a/package/firmware/layerscape/ls-rcw/Makefile
+++ b/package/firmware/layerscape/ls-rcw/Makefile
@@ -28,6 +28,11 @@ define Package/layerscape-rcw/Config
endef
endef
+define Package/layerscape-rcw/ls1012afrdm
+ TITLE:=NXP LS1012AFRDM RCW binary
+ CONFIG:=ls1012afrdm/N_SSNP_3305/rcw_800.bin
+endef
+
define Package/layerscape-rcw/ls1012ardb
TITLE:=NXP LS1012ARDB RCW binary
CONFIG:=ls1012ardb/R_SPNH_3508/rcw_1000_default.bin
@@ -86,6 +91,7 @@ define Package/layerscape-rcw/Install
endef
RCWS := \
+ ls1012afrdm \
ls1012ardb \
ls1012afrwy \
ls1043ardb \