aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-02-16 23:43:50 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 19:22:39 +0100
commitce8226a97133a7b105d9c626ff47a401b61748cd (patch)
tree531d28cfdc0be7cad572355e2c1a0a8d96adc083 /package/devel
parentb494734367d4db32453e6fea3e1ed501ecf3ef49 (diff)
downloadupstream-ce8226a97133a7b105d9c626ff47a401b61748cd.tar.gz
upstream-ce8226a97133a7b105d9c626ff47a401b61748cd.tar.bz2
upstream-ce8226a97133a7b105d9c626ff47a401b61748cd.zip
strace: Only allow libdw or libunwind
These two dependencies are mutual exclusive and it is only possible to select one of them, change the select to a chose so it is only possible to select one of them in OpenWrt menu config. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 55fdc80c1b..dd7f31eeeb 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -57,17 +57,19 @@ system calls a program makes while it is running.
endef
define Package/strace/config
-menu "Select strace configuration options"
- depends on PACKAGE_strace
+choice
+ prompt "stack tracing support"
+ default STRACE_NONE
-config STRACE_LIBDW
- bool "Enable stack tracing support using libdw"
- default n
-config STRACE_LIBUNWIND
- bool "Enable stack tracing support using libunwind (experimental)"
- default n
+ config STRACE_NONE
+ bool "None"
-endmenu
+ config STRACE_LIBDW
+ bool "libdw"
+
+ config STRACE_LIBUNWIND
+ bool "libunwind (experimental)"
+endchoice
endef
CONFIGURE_ARGS += \