aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2019-02-10 14:46:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 19:22:39 +0100
commitb494734367d4db32453e6fea3e1ed501ecf3ef49 (patch)
tree96e18e984fcef304bf708bc88008f25ccecd96c6 /package/devel
parent0297610554def2ed4f5c039bf277047945d40ca1 (diff)
downloadupstream-b494734367d4db32453e6fea3e1ed501ecf3ef49.tar.gz
upstream-b494734367d4db32453e6fea3e1ed501ecf3ef49.tar.bz2
upstream-b494734367d4db32453e6fea3e1ed501ecf3ef49.zip
strace: fix configuration options
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index c4761a4693..55fdc80c1b 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -23,9 +23,12 @@ PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_FIXUP:=autoreconf
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_strace_libunwind
PKG_INSTALL:=1
+PKG_CONFIG_DEPENDS := \
+ CONFIG_STRACE_LIBDW \
+ CONFIG_STRACE_LIBUNWIND
+
include $(INCLUDE_DIR)/package.mk
HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
@@ -44,7 +47,7 @@ define Package/strace
SECTION:=utils
CATEGORY:=Utilities
TITLE:=System call tracer
- DEPENDS:=+PACKAGE_strace_libunwind:libunwind
+ DEPENDS:=+STRACE_LIBDW:libdw +STRACE_LIBUNWIND:libunwind
URL:=http://strace.sourceforge.net/
endef
@@ -54,17 +57,22 @@ system calls a program makes while it is running.
endef
define Package/strace/config
-config PACKAGE_strace_libdw
+menu "Select strace configuration options"
+ depends on PACKAGE_strace
+
+config STRACE_LIBDW
bool "Enable stack tracing support using libdw"
default n
-config PACKAGE_strace_libunwind
+config STRACE_LIBUNWIND
bool "Enable stack tracing support using libunwind (experimental)"
default n
+
+endmenu
endef
CONFIGURE_ARGS += \
- --with-libdw=$(if $(CONFIG_PACKAGE_strace_libdw),yes,no) \
- --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+ --with-libdw=$(if $(CONFIG_STRACE_LIBDW),yes,no) \
+ --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no)
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"