aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-05-12 15:23:01 +0200
committerFelix Fietkau <nbd@nbd.name>2020-06-04 21:52:57 +0200
commit2dd26fda16a4574c91d02f4b1ccb2ce121e764c8 (patch)
tree7f5d777032c81d484db0431cb7da9f6738249d5d /package/devel
parent5aa2ddd0d6b9759c62bbb7bb11b72a7f4269c16b (diff)
downloadupstream-2dd26fda16a4574c91d02f4b1ccb2ce121e764c8.tar.gz
upstream-2dd26fda16a4574c91d02f4b1ccb2ce121e764c8.tar.bz2
upstream-2dd26fda16a4574c91d02f4b1ccb2ce121e764c8.zip
kernel: fix portability issue with perf on linux 5.4
Remove dependencies on core kernel headers in host tools used to build perf, which break on any non-linux system Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index aa478a0431..3bb403916b 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -36,6 +36,8 @@ define Package/perf/description
perf is the Linux performance monitoring tool
endef
+HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
+
MAKE_FLAGS = \
ARCH="$(LINUX_KARCH)" \
NO_LIBPERL=1 \
@@ -54,6 +56,7 @@ MAKE_FLAGS = \
LD="$(TARGET_CROSS)ld" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
+ KBUILD_HOSTCFLAGS="$(HOST_CFLAGS)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
WERROR=0 \
O=$(PKG_BUILD_DIR) \