aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/perf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel/perf/Makefile')
-rw-r--r--package/devel/perf/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index aa478a0431..3bb403916b 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -36,6 +36,8 @@ define Package/perf/description
perf is the Linux performance monitoring tool
endef
+HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
+
MAKE_FLAGS = \
ARCH="$(LINUX_KARCH)" \
NO_LIBPERL=1 \
@@ -54,6 +56,7 @@ MAKE_FLAGS = \
LD="$(TARGET_CROSS)ld" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
+ KBUILD_HOSTCFLAGS="$(HOST_CFLAGS)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
WERROR=0 \
O=$(PKG_BUILD_DIR) \