aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-23 20:15:17 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-25 19:28:42 +0200
commit7f1540cc46333e9f96237e0084c554a9ec59068c (patch)
treeffce165b07798c0d42288d47d8060913ee7edf9e /package/boot/uboot-at91
parent186569e2e8aac5847ee125c127d500ba024fde0e (diff)
downloadupstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.gz
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.bz2
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.zip
at91: introduce vendor_model scheme and drop board names
This introduces the vendor_model scheme to this target in order to harmonize device names within the target and with the rest of OpenWrt. In addition, custom board names are dropped in favor of the generic script which takes the compatible. Use the SUPPORTED_DEVICES variable to store the compatible where it deviates from the device name, so we can use it in build recipes. While at it, harmonize a few indents as well. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile38
1 files changed, 19 insertions, 19 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 1fb32d4a89..ad10527699 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION:=linux4sam-2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
@@ -27,89 +27,89 @@ endef
define U-Boot/at91sam9m10g45ek_nandflash
NAME:=AT91SAM9M10G45-EK board (NandFlash)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9m10g45ek
+ BUILD_DEVICES:=atmel_at91sam9m10g45ek
endef
define U-Boot/at91sam9x5ek_nandflash
NAME:=AT91SAM9X5-EK board (NandFlash)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
- at91sam9g35ek at91sam9x25ek \
- at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9g15ek atmel_at91sam9g25ek \
+ atmel_at91sam9g35ek atmel_at91sam9x25ek \
+ atmel_at91sam9x35ek
endef
define U-Boot/at91sam9x5ek_mmc
NAME:=AT91SAM9X5-EK board (SDcard)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
- at91sam9g35ek at91sam9x25ek \
- at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9g15ek atmel_at91sam9g25ek \
+ atmel_at91sam9g35ek atmel_at91sam9x25ek \
+ atmel_at91sam9x35ek
endef
define U-Boot/sama5d3_xplained_nandflash
NAME:=SAMA5D3 Xplained board (NandFlash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d3_xplained_mmc
NAME:=SAMA5D3 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d2_xplained_spiflash
NAME:=SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define U-Boot/sama5d2_xplained_mmc
NAME:=SAMA5D2 Xplained board (SDcard/EMMC)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define U-Boot/sama5d4_xplained_spiflash
NAME:=SAMA5D4 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define U-Boot/sama5d4_xplained_mmc
NAME:=SAMA5D4 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define U-Boot/sama5d4_xplained_nandflash
NAME:=SAMA5D4 Xplained board (NandFlash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d27_som1_ek_mmc1
NAME:=SAMA5D27 SOM1 Ek (SDCard1)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define U-Boot/sama5d27_som1_ek_qspiflash
NAME:=SAMA5D27 SOM1 Ek (QSPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define U-Boot/sama5d2_ptc_ek_nandflash
NAME:=SAMA5D2 PTC Ek (Nand Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
define U-Boot/sama5d2_ptc_ek_mmc
NAME:=SAMA5D2 PTC Ek (SDCard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
UBOOT_TARGETS := \