aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-23 20:15:17 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-25 19:28:42 +0200
commit7f1540cc46333e9f96237e0084c554a9ec59068c (patch)
treeffce165b07798c0d42288d47d8060913ee7edf9e
parent186569e2e8aac5847ee125c127d500ba024fde0e (diff)
downloadupstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.gz
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.bz2
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.zip
at91: introduce vendor_model scheme and drop board names
This introduces the vendor_model scheme to this target in order to harmonize device names within the target and with the rest of OpenWrt. In addition, custom board names are dropped in favor of the generic script which takes the compatible. Use the SUPPORTED_DEVICES variable to store the compatible where it deviates from the device name, so we can use it in build recipes. While at it, harmonize a few indents as well. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/boot/at91bootstrap/Makefile32
-rw-r--r--package/boot/uboot-at91/Makefile38
-rwxr-xr-xtarget/linux/at91/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/at91/base-files/lib/at91.sh92
-rw-r--r--target/linux/at91/base-files/lib/preinit/01_preinit_do_at91.sh7
-rw-r--r--target/linux/at91/image/Makefile13
-rw-r--r--target/linux/at91/image/sam9x.mk123
-rw-r--r--target/linux/at91/image/sama5.mk66
-rw-r--r--target/linux/at91/image/uboot-env.txt8
9 files changed, 152 insertions, 229 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index eaec26b4a1..08fe2a49b0 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=at91bootstrap
PKG_VERSION:=v3.9.3
-PKG_RELEASE:=
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
@@ -30,91 +30,91 @@ endef
define AT91Bootstrap/at91sam9x5eknf_uboot
NAME:=AT91Bootstrap for AT91SAM9X5-EK board (NandFlash)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
endef
define AT91Bootstrap/at91sam9x5eksd_uboot
NAME:=AT91Bootstrap for AT91SAM9X5-EK board (SDcard)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
endef
define AT91Bootstrap/sama5d2_xplaineddf_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define AT91Bootstrap/sama5d2_xplainedsd_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define AT91Bootstrap/sama5d3_xplainednf_uboot
TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define AT91Bootstrap/sama5d3_xplainedsd_uboot
TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define AT91Bootstrap/sama5d27_som1_eksd_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define AT91Bootstrap/sama5d27_som1_eksd1_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define AT91Bootstrap/sama5d2_ptc_eknf_uboot
TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
define AT91Bootstrap/sama5d2_ptc_eksd_uboot
TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (SDCard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
AT91BOOTSTRAP_TARGETS := \
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 1fb32d4a89..ad10527699 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION:=linux4sam-2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
@@ -27,89 +27,89 @@ endef
define U-Boot/at91sam9m10g45ek_nandflash
NAME:=AT91SAM9M10G45-EK board (NandFlash)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9m10g45ek
+ BUILD_DEVICES:=atmel_at91sam9m10g45ek
endef
define U-Boot/at91sam9x5ek_nandflash
NAME:=AT91SAM9X5-EK board (NandFlash)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
- at91sam9g35ek at91sam9x25ek \
- at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9g15ek atmel_at91sam9g25ek \
+ atmel_at91sam9g35ek atmel_at91sam9x25ek \
+ atmel_at91sam9x35ek
endef
define U-Boot/at91sam9x5ek_mmc
NAME:=AT91SAM9X5-EK board (SDcard)
BUILD_SUBTARGET:=sam9x
- BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
- at91sam9g35ek at91sam9x25ek \
- at91sam9x35ek
+ BUILD_DEVICES:=atmel_at91sam9g15ek atmel_at91sam9g25ek \
+ atmel_at91sam9g35ek atmel_at91sam9x25ek \
+ atmel_at91sam9x35ek
endef
define U-Boot/sama5d3_xplained_nandflash
NAME:=SAMA5D3 Xplained board (NandFlash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d3_xplained_mmc
NAME:=SAMA5D3 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d2_xplained_spiflash
NAME:=SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define U-Boot/sama5d2_xplained_mmc
NAME:=SAMA5D2 Xplained board (SDcard/EMMC)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_xplained
+ BUILD_DEVICES:=microchip_sama5d2-xplained
endef
define U-Boot/sama5d4_xplained_spiflash
NAME:=SAMA5D4 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define U-Boot/sama5d4_xplained_mmc
NAME:=SAMA5D4 Xplained board (SDcard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d4-xplained
endef
define U-Boot/sama5d4_xplained_nandflash
NAME:=SAMA5D4 Xplained board (NandFlash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d4_xplained
+ BUILD_DEVICES:=microchip_sama5d3-xplained
endef
define U-Boot/sama5d27_som1_ek_mmc1
NAME:=SAMA5D27 SOM1 Ek (SDCard1)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define U-Boot/sama5d27_som1_ek_qspiflash
NAME:=SAMA5D27 SOM1 Ek (QSPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d27_som1_ek
+ BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
define U-Boot/sama5d2_ptc_ek_nandflash
NAME:=SAMA5D2 PTC Ek (Nand Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
define U-Boot/sama5d2_ptc_ek_mmc
NAME:=SAMA5D2 PTC Ek (SDCard)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d2_ptc_ek
+ BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
UBOOT_TARGETS := \
diff --git a/target/linux/at91/base-files/etc/board.d/02_network b/target/linux/at91/base-files/etc/board.d/02_network
index 66f9d88fae..306dfe375e 100755
--- a/target/linux/at91/base-files/etc/board.d/02_network
+++ b/target/linux/at91/base-files/etc/board.d/02_network
@@ -9,7 +9,7 @@ board_config_update
case "$(board_name)" in
-sama5d3_xplained)
+atmel,sama5d3-xplained)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
;;
diff --git a/target/linux/at91/base-files/lib/at91.sh b/target/linux/at91/base-files/lib/at91.sh
deleted file mode 100644
index 19a63e1200..0000000000
--- a/target/linux/at91/base-files/lib/at91.sh
+++ /dev/null
@@ -1,92 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-
-AT91_BOARD_NAME=
-AT91_MODEL=
-
-at91_board_detect() {
- local machine
- local name
-
- machine=$(cat /proc/device-tree/model)
-
- case "$machine" in
- *"Atmel at91sam9263ek")
- name="at91sam9263ek"
- ;;
- *"Atmel AT91SAM9G15-EK")
- name="at91sam9g15ek"
- ;;
- *"Atmel at91sam9g20ek")
- name="at91sam9g20ek"
- ;;
- *"Atmel at91sam9g20ek 2 mmc")
- name="at91sam9g20ek_2mmc"
- ;;
- *"Atmel AT91SAM9G25-EK")
- name="at91sam9g25ek"
- ;;
- *"Atmel AT91SAM9G35-EK")
- name="at91sam9g35ek"
- ;;
- *"Atmel AT91SAM9M10G45-EK")
- name="at91sam9m10g45ek"
- ;;
- *"Atmel AT91SAM9X25-EK")
- name="at91sam9x25ek"
- ;;
- *"Atmel AT91SAM9X35-EK")
- name="at91sam9x35ek"
- ;;
- *"SAMA5D3 Xplained")
- name="sama5d3_xplained"
- ;;
- *"Atmel SAMA5D27 SOM1 EK")
- name="sama5d27_som1_ek"
- ;;
- *"Atmel SAMA5D2 PTC EK")
- name="sama5d2_ptc_ek"
- ;;
- *"SAMA5D2 Xplained")
- name="sama5d2_xplained"
- ;;
- *"SAMA5D4 Xplained")
- name="sama5d4_xplained"
- ;;
- *"CalAmp LMU5000")
- name="lmu5000"
- ;;
- *"Calao TNY A9260")
- name="tny_a9260"
- ;;
- *"Calao TNY A9263")
- name="tny_a9263"
- ;;
- *"Calao TNY A9G20")
- name="tny_a9g20"
- ;;
- *"Calao USB A9260")
- name="usb_a9260"
- ;;
- *"Calao USB A9263")
- name="usb_a9263"
- ;;
- *"Calao USB A9G20")
- name="usb_a9g20"
- ;;
- *"Ethernut 5")
- name="ethernut5"
- ;;
- esac
-
- [ -z "$name" ] && name="unknown"
-
- [ -z "$AT91_BOARD_NAME" ] && AT91_BOARD_NAME="$name"
- [ -z "$AT91_MODEL" ] && AT91_MODEL="$machine"
-
- [ -e "/tmp/sysinfo/" ] || mkdir -p "/tmp/sysinfo/"
-
- echo "$AT91_BOARD_NAME" > /tmp/sysinfo/board_name
- echo "$AT91_MODEL" > /tmp/sysinfo/model
-}
diff --git a/target/linux/at91/base-files/lib/preinit/01_preinit_do_at91.sh b/target/linux/at91/base-files/lib/preinit/01_preinit_do_at91.sh
deleted file mode 100644
index c812329568..0000000000
--- a/target/linux/at91/base-files/lib/preinit/01_preinit_do_at91.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-do_at91() {
- . /lib/at91.sh
-
- at91_board_detect
-}
-
-boot_hook_add preinit_main do_at91
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 959b1cb0a3..05f0b58af7 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x20008000
define Build/at91-install-zImage
- $(CP) $(KDIR)/zImage $@
+ $(CP) $(KDIR)/zImage $@
endef
include $(SUBTARGET).mk
@@ -24,7 +24,8 @@ define Device/Default
$(Device/default-nand)
PROFILES := Default
FILESYSTEMS := squashfs ubifs ext4
- DEVICE_DTS := $(1)
+ DEVICE_DTS = $(lastword $(subst _, ,$(1)))
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
KERNEL_NAME := zImage
KERNEL_SIZE := 4096k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
@@ -56,13 +57,13 @@ define Device/evaluation-dtb
$(Device/evaluation)
$(Device/dtb)
KERNEL_SUFFIX := -fit-zImage.itb
- KERNEL := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
endef
define Device/evaluation-fit
$(Device/evaluation)
KERNEL_SUFFIX := -fit-uImage.itb
- KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
endef
define Device/production
@@ -74,8 +75,8 @@ endef
define Device/production-dtb
$(Device/production)
$(Device/dtb)
- IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
- | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) | \
+ append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
$(eval $(call BuildImage))
diff --git a/target/linux/at91/image/sam9x.mk b/target/linux/at91/image/sam9x.mk
index beff346725..bbe410fbfb 100644
--- a/target/linux/at91/image/sam9x.mk
+++ b/target/linux/at91/image/sam9x.mk
@@ -1,3 +1,4 @@
+
define Device/default-nand
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -15,169 +16,181 @@ define Build/at91-sdcard
::$(DEVICE_NAME)-fit.itb
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-at91sam9x5ek_mmc/u-boot.bin \
- ::u-boot.bin
+ $(BIN_DIR)/u-boot-at91sam9x5ek_mmc/u-boot.bin \
+ ::u-boot.bin
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-at91sam9x5eksd_uboot/at91bootstrap.bin \
- ::BOOT.bin
+ $(BIN_DIR)/at91bootstrap-at91sam9x5eksd_uboot/at91bootstrap.bin \
+ ::BOOT.bin
$(CP) uboot-env.txt $@-uboot-env.txt
sed -i '2d;3d' $@-uboot-env.txt
sed -i '2i board='"$(DEVICE_NAME)"'' $@-uboot-env.txt
- sed -i '3i board_name='"$(DEVICE_NAME)"'' $@-uboot-env.txt
+ sed -i '3i board_name='"$(firstword $(SUPPORTED_DEVICES))"'' $@-uboot-env.txt
mkenvimage -s 0x4000 -o $@-uboot.env $@-uboot-env.txt
mcopy -i $@.boot $@-uboot.env ::uboot.env
./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
gzip -nc9 $@.img > $@
rm -f $@.img $@.boot $@-uboot.env $@-uboot-env.txt)
endef
-define Device/at91sam9263ek
+define Device/atmel_at91sam9263ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9263-EK
endef
-TARGET_DEVICES += at91sam9263ek
+TARGET_DEVICES += atmel_at91sam9263ek
-define Device/at91sam9g15ek
+define Device/atmel_at91sam9g15ek
$(Device/evaluation)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9G15-EK
endef
-TARGET_DEVICES += at91sam9g15ek
+TARGET_DEVICES += atmel_at91sam9g15ek
-define Device/at91sam9g20ek
+define Device/atmel_at91sam9g20ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9G20-EK
endef
-TARGET_DEVICES += at91sam9g20ek
+TARGET_DEVICES += atmel_at91sam9g20ek
-define Device/at91sam9g20ek_2mmc
+define Device/atmel_at91sam9g20ek-2mmc
$(Device/evaluation-dtb)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9G20-EK
DEVICE_VARIANT := 2MMC
+ DEVICE_DTS := at91sam9g20ek_2mmc
+ SUPPORTED_DEVICES := atmel,at91sam9g20ek_2mmc
endef
-TARGET_DEVICES += at91sam9g20ek_2mmc
+TARGET_DEVICES += atmel_at91sam9g20ek-2mmc
-define Device/at91sam9g25ek
+define Device/atmel_at91sam9g25ek
$(Device/evaluation)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9G25-EK
endef
-TARGET_DEVICES += at91sam9g25ek
+TARGET_DEVICES += atmel_at91sam9g25ek
-define Device/at91sam9g35ek
+define Device/atmel_at91sam9g35ek
$(Device/evaluation)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9G35-EK
endef
-TARGET_DEVICES += at91sam9g35ek
+TARGET_DEVICES += atmel_at91sam9g35ek
-define Device/at91sam9m10g45ek
+define Device/atmel_at91sam9m10g45ek
$(Device/evaluation)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9M10G45-EK
endef
-TARGET_DEVICES += at91sam9m10g45ek
+TARGET_DEVICES += atmel_at91sam9m10g45ek
-define Device/at91sam9x25ek
+define Device/atmel_at91sam9x25ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9X25-EK
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91sam9x25ek
+TARGET_DEVICES += atmel_at91sam9x25ek
-define Device/at91sam9x35ek
+define Device/atmel_at91sam9x35ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Atmel
DEVICE_MODEL := AT91SAM9X35-EK
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91sam9x35ek
+TARGET_DEVICES += atmel_at91sam9x35ek
-define Device/lmu5000
+define Device/calamp_lmu5000
$(Device/production)
DEVICE_VENDOR := CalAmp
DEVICE_MODEL := LMU5000
DEVICE_PACKAGES := kmod-rtc-pcf2123 kmod-usb-acm kmod-usb-serial \
kmod-usb-serial-option kmod-usb-serial-sierrawireless kmod-gpio-mcp23s08
endef
-TARGET_DEVICES += lmu5000
+TARGET_DEVICES += calamp_lmu5000
-define Device/tny_a9260
+define Device/calao_tny-a9260
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := TNYA9260
+ DEVICE_MODEL := TNY A9260
+ DEVICE_DTS := tny_a9260
endef
-TARGET_DEVICES += tny_a9260
+TARGET_DEVICES += calao_tny-a9260
-define Device/tny_a9263
+define Device/calao_tny-a9263
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := TNYA9263
+ DEVICE_MODEL := TNY A9263
+ DEVICE_DTS := tny_a9263
+ SUPPORTED_DEVICES := atmel,tny-a9263
endef
-TARGET_DEVICES += tny_a9263
+TARGET_DEVICES += calao_tny-a9263
-define Device/tny_a9g20
+define Device/calao_tny-a9g20
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := TNYA9G20
+ DEVICE_MODEL := TNY A9G20
+ DEVICE_DTS := tny_a9g20
endef
-TARGET_DEVICES += tny_a9g20
+TARGET_DEVICES += calao_tny-a9g20
-define Device/usb_a9260
+define Device/calao_usb-a9260
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := USBA9260
+ DEVICE_MODEL := USB A9260
+ DEVICE_DTS := usb_a9260
endef
-TARGET_DEVICES += usb_a9260
+TARGET_DEVICES += calao_usb-a9260
-define Device/usb_a9263
+define Device/calao_usb-a9263
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := USBA9263
+ DEVICE_MODEL := USB A9263
+ DEVICE_DTS := usb_a9263
+ SUPPORTED_DEVICES := atmel,usb-a9263
endef
-TARGET_DEVICES += usb_a9263
+TARGET_DEVICES += calao_usb-a9263
-define Device/usb_a9g20
+define Device/calao_usb-a9g20
$(Device/production-dtb)
DEVICE_VENDOR := Calao
- DEVICE_MODEL := USBA9G20
+ DEVICE_MODEL := USB A9G20
+ DEVICE_DTS := usb_a9g20
endef
-TARGET_DEVICES += usb_a9g20
+TARGET_DEVICES += calao_usb-a9g20
-define Device/ethernut5
+define Device/egnite_ethernut5
$(Device/evaluation)
DEVICE_VENDOR := egnite
DEVICE_MODEL := Ethernut 5
UBINIZE_OPTS := -E 5
endef
-TARGET_DEVICES += ethernut5
+TARGET_DEVICES += egnite_ethernut5
-define Device/at91-q5xr5
+define Device/exegin_q5xr5
$(Device/production-dtb)
DEVICE_VENDOR := Exegin
- DEVICE_MODEL := Q5XR5
+ DEVICE_MODEL := Q5x
+ DEVICE_VARIANT := rev5
+ DEVICE_DTS := at91-q5xr5
KERNEL_SIZE := 2048k
DEFAULT := n
endef
-TARGET_DEVICES += at91-q5xr5
+TARGET_DEVICES += exegin_q5xr5
-define Device/wb45n
+define Device/laird_wb45n
$(Device/evaluation-fit)
DEVICE_VENDOR := Laird
DEVICE_MODEL := WB45N
@@ -190,4 +203,4 @@ define Device/wb45n
SUBPAGESIZE := 2048
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
endef
-TARGET_DEVICES += wb45n
+TARGET_DEVICES += laird_wb45n
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 031e62587e..d644f89266 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -13,87 +13,94 @@ define Build/at91-sdcard
mcopy -i $@.boot \
$(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
- ::$(DEVICE_NAME:at91-%=%)-fit.itb
+ ::$(DEVICE_NAME)-fit.itb
- $(if $(findstring at91-sama5d27_som1_ek,$@), \
+ $(if $(findstring sama5d27-som1-ek,$@), \
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc1/u-boot.bin \
+ $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc1/u-boot.bin \
::u-boot.bin
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd1_uboot/at91bootstrap.bin \
::BOOT.bin,
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- $(if $(findstring sama5d4_xplained, $@), \
+ $(if $(findstring sama5d4-xplained,$@), \
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
::BOOT.bin,
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot/at91bootstrap.bin \
::BOOT.bin))
$(CP) uboot-env.txt $@-uboot-env.txt
sed -i '2d;3d' $@-uboot-env.txt
- sed -i '2i board='"$(DEVICE_NAME:at91-%=%)"'' $@-uboot-env.txt
- sed -i '3i board_name='"$(DEVICE_NAME:at91-%=%)"'' $@-uboot-env.txt
+ sed -i '2i board='"$(DEVICE_NAME)"'' $@-uboot-env.txt
+ sed -i '3i board_name='"$(firstword $(SUPPORTED_DEVICES))"'' $@-uboot-env.txt
mkenvimage -s 0x4000 -o $@-uboot.env $@-uboot-env.txt
mcopy -i $@.boot $@-uboot.env ::uboot.env
./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
gzip -nc9 $@.img > $@
rm -f $@.img $@.boot $@-uboot.env $@-uboot-env.txt)
endef
-define Device/at91-sama5d2_xplained
+define Device/microchip_sama5d2-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D2 Xplained
+ DEVICE_DTS := at91-sama5d2_xplained
+ SUPPORTED_DEVICES := atmel,sama5d2-xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d2_xplained
+TARGET_DEVICES += microchip_sama5d2-xplained
-define Device/at91-sama5d27_som1_ek
+define Device/microchip_sama5d27-som1-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D27 SOM1 Ek
+ DEVICE_DTS := at91-sama5d27_som1_ek
+ SUPPORTED_DEVICES := atmel,sama5d27-som1-ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
+TARGET_DEVICES += microchip_sama5d27-som1-ek
-define Device/at91-sama5d2_ptc_ek
+define Device/microchip_sama5d2-ptc-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D2 PTC Ek
+ DEVICE_DTS := at91-sama5d2_ptc_ek
+ SUPPORTED_DEVICES := atmel,sama5d2-ptc_ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d2_ptc_ek
+TARGET_DEVICES += microchip_sama5d2-ptc-ek
-
-define Device/at91-sama5d3_xplained
+define Device/microchip_sama5d3-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D3 Xplained
+ DEVICE_DTS := at91-sama5d3_xplained
+ SUPPORTED_DEVICES := atmel,sama5d3-xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d3_xplained
+TARGET_DEVICES += microchip_sama5d3-xplained
ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
+ define Device/laird_wb50n
$(Device/evaluation-fit)
DEVICE_VENDOR := Laird
DEVICE_MODEL := WB50N
@@ -106,15 +113,16 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
SUBPAGESIZE := 2048
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
endef
- TARGET_DEVICES += wb50n
+ TARGET_DEVICES += laird_wb50n
endif
endif
-
-define Device/at91-sama5d4_xplained
+define Device/microchip_sama5d4-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D4 Xplained
+ DEVICE_DTS := at91-sama5d4_xplained
+ SUPPORTED_DEVICES := atmel,sama5d4-xplained
KERNEL_SIZE := 6144k
BLOCKSIZE := 256k
PAGESIZE := 4096
@@ -122,4 +130,4 @@ define Device/at91-sama5d4_xplained
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d4_xplained
+TARGET_DEVICES += microchip_sama5d4-xplained
diff --git a/target/linux/at91/image/uboot-env.txt b/target/linux/at91/image/uboot-env.txt
index 80d051b72f..9cdccc9a2f 100644
--- a/target/linux/at91/image/uboot-env.txt
+++ b/target/linux/at91/image/uboot-env.txt
@@ -1,13 +1,13 @@
/* Do Not remove First 2 lines, Makefile will modify these lines with proper board names */
-board=at91sam9x25ek
-board_name=at91sam9x25ek
+board=atmel_at91sam9x25ek
+board_name=atmel,at91sam9x25ek
bootargs=console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p2 rw rootwait rootfstype=ext4
bootargsd2=console=ttyS0,115200 earlyprintk root=/dev/mmcblk1p2 rw rootwait rootfstype=ext4
bootargsxx=console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p2 rw rootwait rootfstype=ext4
bootcmd=run setbootargs; run fatload_mmc; bootm 0x21000000
bootdelay=1
-fatload_mmc=if test ${board_name} = sama5d2_xplained || test ${board_name} = sama5d27_som1_ek; then fatload mmc 1:1 0x21000000 ${board_name}-fit.itb; else fatload mmc 0:1 0x21000000 ${board_name}-fit.itb; fi
-setbootargs=if test ${board_name} = sama5d2_xplained || test ${board_name} = sama5d27_som1_ek; then setenv bootargs ${bootargsd2}; else setenv bootargs ${bootargsxx}; fi
+fatload_mmc=if test ${board_name} = atmel,sama5d2-xplained || test ${board_name} = atmel,sama5d27-som1-ek; then fatload mmc 1:1 0x21000000 ${board}-fit.itb; else fatload mmc 0:1 0x21000000 ${board}-fit.itb; fi
+setbootargs=if test ${board_name} = atmel,sama5d2-xplained || test ${board_name} = atmel,sama5d27-som1-ek; then setenv bootargs ${bootargsd2}; else setenv bootargs ${bootargsxx}; fi
ethact=gmac0
stderr=serial
stdin=serial