aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorXu Wang <xwang1498@gmx.com>2020-01-06 17:12:43 +0000
committerJo-Philipp Wich <jo@mein.io>2020-01-14 17:52:34 +0100
commit44304c1d671696ed9598735e71a1635276102511 (patch)
tree750b7c98a45b6ce1236e67c3735931bb2b3ccf77 /package/base-files/Makefile
parent3c77e4ae4d97ec14daeabfab12ec8b451184d0d6 (diff)
downloadupstream-44304c1d671696ed9598735e71a1635276102511.tar.gz
upstream-44304c1d671696ed9598735e71a1635276102511.tar.bz2
upstream-44304c1d671696ed9598735e71a1635276102511.zip
base-files: fix build for /sbin/pkg_check
Setting CONFIG_IPK_FILES_CHECKSUMS=y causes sha256 checksum files to be included with the packages to check for corruption. This commit fixes two issues: - /sbin/pkg_check was being removed incorrectly if IPK_FILES_CHECKSUMS=y - checksums were being saved in the wrong file Signed-off-by: Xu Wang <xwang1498@gmx.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 35ad80888f..268d7d4cc9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -204,8 +204,8 @@ define Package/base-files/install
mkdir -p $(1)/etc/opkg; \
$(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf); \
$(VERSION_SED_SCRIPT) $(1)/etc/opkg/distfeeds.conf)
- $(if $(CONFIG_IPK_FILES_CHECKSUMS), \
- rm -f $(1)/sbin/pkg_check,)
+ $(if $(CONFIG_IPK_FILES_CHECKSUMS),, \
+ rm -f $(1)/sbin/pkg_check)
endef
ifneq ($(DUMP),1)