aboutsummaryrefslogtreecommitdiffstats
path: root/package/admswconfig
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/admswconfig
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/admswconfig')
-rw-r--r--package/admswconfig/Makefile52
-rw-r--r--package/admswconfig/files/admswconfig68
-rw-r--r--package/admswconfig/files/admswswitch.sh28
-rw-r--r--package/admswconfig/patches/001-matrix.patch15
4 files changed, 0 insertions, 163 deletions
diff --git a/package/admswconfig/Makefile b/package/admswconfig/Makefile
deleted file mode 100644
index e16258f4b1..0000000000
--- a/package/admswconfig/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=admswconfig
-PKG_VERSION:=0.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/admswconfig
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=ADM5120 Switch configuration tool
- DEPENDS:=@TARGET_adm5120
- URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-
-define Package/admswconfig/description
- A program to configure the internal ethernet switch of an ADM5120 processor.
- You need the corresponding driver for the switch in the kernel.
- With this program you can configure which ports of the switch belong
- to the different ethernet devices.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Os $(PKG_BUILD_DIR)/admswconfig.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Package/admswconfig/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
- $(INSTALL_DIR) $(1)/lib/network/
- $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
-endef
-
-$(eval $(call BuildPackage,admswconfig))
diff --git a/package/admswconfig/files/admswconfig b/package/admswconfig/files/admswconfig
deleted file mode 100644
index 7231030650..0000000000
--- a/package/admswconfig/files/admswconfig
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-START=05
-
-start() {
- [ -e /etc/config/network ] && exit 0
-
- mkdir -p /etc/config
-
- board_name=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /system type/ {print $2}' /proc/cpuinfo)
-
- case "$board_name" in
- "Compex WP54"*)
- board="Compex WP54";;
- esac
-
- echo "$board" |awk '
- function p(cfgname, name) {
- if (c[name] != "") print " option " cfgname " \"" c[name] "\""
- }
-
- BEGIN {
- FS="="
- c["lan_ifname"]="eth0"
- c["wan_ifname"]="eth1"
- c["eth0ports"]="1 2 3 4"
- c["eth1ports"]="0"
- }
- END {
- board=$1
- if (board == "Compex WP54") {
- c["eth0ports"]="0"
- c["eth1ports"]="1"
- }
-
- print "#### VLAN configuration "
- print "config switch"
- p("eth0", "eth0ports")
- p("eth1", "eth1ports")
- print ""
- print ""
- print "#### Loopback configuration"
- print "config interface loopback"
- print " option ifname \"lo\""
- print " option proto static"
- print " option ipaddr 127.0.0.1"
- print " option netmask 255.0.0.0"
- print ""
- print ""
- print "#### LAN configuration"
- print "config interface lan"
- print " option type bridge"
- p("ifname", "lan_ifname")
- p("macaddr", "lan_macaddr")
- print " option proto static"
- print " option ipaddr 192.168.1.1"
- print " option netmask 255.255.255.0"
- print ""
- print ""
- print "#### WAN configuration"
- print "config interface wan"
- p("ifname", "wan_ifname")
- p("macaddr", "wan_macaddr")
- print " option proto dhcp"
- }' > /etc/config/network
-}
-
diff --git a/package/admswconfig/files/admswswitch.sh b/package/admswconfig/files/admswswitch.sh
deleted file mode 100644
index 984d7eea79..0000000000
--- a/package/admswconfig/files/admswswitch.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
-
-setup_switch_vlan() {
- config_get ports "$CONFIG_SECTION" "eth$1"
- ports=`echo "$ports"| sed s/" "/""/g`
- ifconfig eth$1 down
- admswconfig eth$1 ${ports}c
- ifconfig eth$1 up
-}
-
-setup_switch() {
- config_cb() {
- case "$1" in
- switch)
- option_cb() {
- case "$1" in
- eth*) setup_switch_vlan "${1##eth}";;
- esac
- }
- ;;
- *)
- option_cb() { return 0; }
- ;;
- esac
- }
- config_load network
-}
diff --git a/package/admswconfig/patches/001-matrix.patch b/package/admswconfig/patches/001-matrix.patch
deleted file mode 100644
index e50d515757..0000000000
--- a/package/admswconfig/patches/001-matrix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/admswconfig.c
-+++ b/admswconfig.c
-@@ -111,9 +111,9 @@ int main(int argc, char **argv)
- }
- } else {
- /* display matrix */
-- printf("ethX\tport0\tport1\tport2\tport3\tport4");
-- if (info.ports == 6)
-- printf("\tport5");
-+ printf("ethX");
-+ for (i = 0; i < info.ports; i++)
-+ printf("\tport%d", i);
- printf("\tCPU\n");
- for (i = 0; i < info.ports; i++) {
- printf("%d", i);