aboutsummaryrefslogtreecommitdiffstats
path: root/package/admswconfig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/admswconfig/Makefile')
-rw-r--r--package/admswconfig/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/package/admswconfig/Makefile b/package/admswconfig/Makefile
deleted file mode 100644
index e16258f4b1..0000000000
--- a/package/admswconfig/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=admswconfig
-PKG_VERSION:=0.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/admswconfig
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=ADM5120 Switch configuration tool
- DEPENDS:=@TARGET_adm5120
- URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-
-define Package/admswconfig/description
- A program to configure the internal ethernet switch of an ADM5120 processor.
- You need the corresponding driver for the switch in the kernel.
- With this program you can configure which ports of the switch belong
- to the different ethernet devices.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Os $(PKG_BUILD_DIR)/admswconfig.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Package/admswconfig/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
- $(INSTALL_DIR) $(1)/lib/network/
- $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
-endef
-
-$(eval $(call BuildPackage,admswconfig))