aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:37:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:37:05 +0000
commitedbb32897ac070c3a9462e1fd9fa21d135d642b9 (patch)
tree9aa38b532ac4056c01fd26b8dd1e83aa0267bb20 /package/Makefile
parent35497a04001210a9288b70e9d05afab62ce84c76 (diff)
downloadupstream-edbb32897ac070c3a9462e1fd9fa21d135d642b9.tar.gz
upstream-edbb32897ac070c3a9462e1fd9fa21d135d642b9.tar.bz2
upstream-edbb32897ac070c3a9462e1fd9fa21d135d642b9.zip
build: trigger pacakge index creation for all feeds if required
When CONFIG_PER_FEED_REPO_ADD_DISABLED is set, trigger index creation for any available feed, regardless of whether there where binaries built or not. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45765
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 94b807f5d5..a601dcbb31 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -132,7 +132,11 @@ endif
PACKAGE_SUBDIRS=.
ifneq ($(CONFIG_PER_FEED_REPO),)
- PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+ ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+ PACKAGE_SUBDIRS=base $(FEEDS_AVAILABLE)
+ else
+ PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+ endif
endif
$(curdir)/index: FORCE