aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2016-12-24 13:32:26 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-26 11:17:33 +0100
commitc24172cad1e66412b287cf49809d363e10acb1c5 (patch)
treec039f023ffe56dfac099410997c479dedac4a0fe /package/Makefile
parent4c4047ec19edcaf39ec83728904d1081bf848894 (diff)
downloadupstream-c24172cad1e66412b287cf49809d363e10acb1c5.tar.gz
upstream-c24172cad1e66412b287cf49809d363e10acb1c5.tar.bz2
upstream-c24172cad1e66412b287cf49809d363e10acb1c5.zip
package/Makefile & ipkg-make-index.sh: add full package data list
The external script used to generate the package lists for the LEDE wiki's table of packages [1] and package indexes [2] requires a "Source:" field in the package lists to find package makefiles. The package makefiles are used to read the package's Category and Submenu. The "Source:" field was removed in commit b4aa3c899cbf1f81cd8a1ea197481ac84a9d646e to reduce package list sizes and lessen opkg issues in low ram devices. Add a separate package list file with full data to be used by the wiki's script. It's called Packages.manifest and isn't compressed as it's not necessary. 1. https://lede-project.org/packages/start 2. https://lede-project.org/packages/index/start Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 64efeb3745..17378a95ef 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -88,7 +88,8 @@ $(curdir)/index: FORCE
@for d in $(PACKAGE_SUBDIRS); do ( \
mkdir -p $$d; \
cd $$d || continue; \
- $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
+ $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
+ grep -vE '^(Maintainer|LicenseFiles|Source|Require)' Packages.manifest > Packages && \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES