aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-22 12:22:16 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-29 10:18:26 +0200
commit731b166528658e0b89f6bd0e589f029eb665f7a6 (patch)
tree4b05676849fce2973bb5c49b6d99a1b3407c264f /package/Makefile
parent5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a (diff)
downloadupstream-731b166528658e0b89f6bd0e589f029eb665f7a6.tar.gz
upstream-731b166528658e0b89f6bd0e589f029eb665f7a6.tar.bz2
upstream-731b166528658e0b89f6bd0e589f029eb665f7a6.zip
build: add template for getting opkg package files from package names
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index 87dfe68e06..f5a7395643 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -49,11 +49,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
$(call opkg,$(TARGET_DIR)) install \
- $(wildcard \
- $(foreach dir,$(PACKAGE_SUBDIRS), \
- $(foreach pkg, \
- $(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null), \
- $(dir)/$(pkg)_*.ipk)))
+ $(call opkg_package_files,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null))
@for file in $(PACKAGE_INSTALL_FILES); do \
[ -s $$file.flags ] || continue; \
for flag in `cat $$file.flags`; do \