aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-22 12:10:17 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-29 10:18:26 +0200
commit5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a (patch)
tree101ad64ef54238bba17043bb4d6b8423bff6a2bb /package/Makefile
parent37e82e4e42155901756a67ad14f3d5c1335f3b0a (diff)
downloadupstream-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.tar.gz
upstream-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.tar.bz2
upstream-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.zip
build: rework opkg command invocation
Drop included $(XARGS), add support for passing target dir via parameter Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 857c2ebe38..87dfe68e06 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -48,11 +48,16 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
- @echo $(wildcard $(foreach dir,$(PACKAGE_SUBDIRS),$(foreach pkg,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null),$(dir)/$(pkg)_*.ipk))) | $(OPKG) install
+ $(call opkg,$(TARGET_DIR)) install \
+ $(wildcard \
+ $(foreach dir,$(PACKAGE_SUBDIRS), \
+ $(foreach pkg, \
+ $(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null), \
+ $(dir)/$(pkg)_*.ipk)))
@for file in $(PACKAGE_INSTALL_FILES); do \
[ -s $$file.flags ] || continue; \
for flag in `cat $$file.flags`; do \
- $(OPKG) flag $$flag < $$file; \
+ $(call opkg,$(TARGET_DIR)) flag $$flag `cat $$file`; \
done; \
done || true
@-$(MAKE) package/preconfig