aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-02-25 14:06:14 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-02-25 14:07:20 +0000
commitf074541f317fd873c28129992ea239552c4f5460 (patch)
treef247286c20667ed824e49c81d3fadb8b0179d729 /include
parent4b92663f7a9f6310c6a3042944fde4876ad9a639 (diff)
downloadupstream-f074541f317fd873c28129992ea239552c4f5460.tar.gz
upstream-f074541f317fd873c28129992ea239552c4f5460.tar.bz2
upstream-f074541f317fd873c28129992ea239552c4f5460.zip
image: remove bogus mkimage command
That was a left-over from testing and should not have made it into the tree. Remove it. Fixes: 330bd380e8 ("image: allow building FIT and uImage with ramdisk") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index d4ec51ca7c..a1edc3265e 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -461,22 +461,6 @@ define Build/uImage
mv $@.new $@
endef
-define Build/uImage-with-ramdisk
- mkimage \
- -A $(LINUX_KARCH) \
- -O linux \
- -T kernel \
- -C $(word 1,$(1)) \
- -a $(KERNEL_LOADADDR) \
- -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -i $(KERNEL_BUILD_DIR)/initrd.cpio.$(strip $(call Build/initrd_compression)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
- $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC)) \
- $(wordlist 2,$(words $(1)),$(1)) \
- -d $@ $@.new
- mv $@.new $@
-endef
-
define Build/xor-image
$(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
mv $@.xor $@