aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index d4ec51ca7c..a1edc3265e 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -461,22 +461,6 @@ define Build/uImage
mv $@.new $@
endef
-define Build/uImage-with-ramdisk
- mkimage \
- -A $(LINUX_KARCH) \
- -O linux \
- -T kernel \
- -C $(word 1,$(1)) \
- -a $(KERNEL_LOADADDR) \
- -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -i $(KERNEL_BUILD_DIR)/initrd.cpio.$(strip $(call Build/initrd_compression)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
- $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC)) \
- $(wordlist 2,$(words $(1)),$(1)) \
- -d $@ $@.new
- mv $@.new $@
-endef
-
define Build/xor-image
$(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
mv $@.xor $@