aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-05 00:06:27 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-05 00:06:27 +0200
commitd3ddf6631e491a831617a5ae8b3d7924e47a275a (patch)
treebac2a9494bfceda3a69118e2071e75ee4f737da9 /include/subdir.mk
parent6031ab345df86c285ea55d6523d6888cc596f63d (diff)
downloadupstream-d3ddf6631e491a831617a5ae8b3d7924e47a275a.tar.gz
upstream-d3ddf6631e491a831617a5ae8b3d7924e47a275a.tar.bz2
upstream-d3ddf6631e491a831617a5ae8b3d7924e47a275a.zip
build: remove GNU time dependency
Replace the GNU time program invocation with a simple Perl script reporting the timing values. Since we require Perl anyway for the build system, we can as well use that instead of requiring a random GNU utility rarely installed by default. Fixes: ff6e62b288 ("build: log time taken by each packages/steps") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index dde3e50b0b..6512e24c2e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -43,7 +43,7 @@ log_make = \
$(if $(BUILD_LOG), \
set -o pipefail; \
mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
- env time -f "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)\#%U\#%S\#%e" -- \
+ $(SCRIPT_DIR)/time.pl "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)" \
$$(SUBMAKE) $(subdir_make_opts) $(if $(3),$(3)-)$(2) \
$(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2).txt)