aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk5
-rw-r--r--include/subdir.mk2
-rwxr-xr-xscripts/time.pl42
3 files changed, 43 insertions, 6 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 029249f69c..a416a2d232 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -138,11 +138,6 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
$(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
-$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time' that supports -f, \
- gtime --version 2>&1 | grep GNU, \
- time --version 2>&1 | grep GNU, \
- busybox time 2>&1 | grep -- '-f FMT'))
-
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
diff --git a/include/subdir.mk b/include/subdir.mk
index dde3e50b0b..6512e24c2e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -43,7 +43,7 @@ log_make = \
$(if $(BUILD_LOG), \
set -o pipefail; \
mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
- env time -f "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)\#%U\#%S\#%e" -- \
+ $(SCRIPT_DIR)/time.pl "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)" \
$$(SUBMAKE) $(subdir_make_opts) $(if $(3),$(3)-)$(2) \
$(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2).txt)
diff --git a/scripts/time.pl b/scripts/time.pl
new file mode 100755
index 0000000000..cdc5824c83
--- /dev/null
+++ b/scripts/time.pl
@@ -0,0 +1,42 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+use Time::HiRes qw(gettimeofday);
+
+if (@ARGV < 2) {
+ die "Usage: $0 <prefix> <command...>\n";
+}
+
+my ($prefix, @cmd) = @ARGV;
+my ($sec, $msec) = gettimeofday();
+my $pid = fork();
+
+if (!defined($pid)) {
+ die "$0: Failure to fork(): $!\n";
+}
+elsif ($pid == 0) {
+ exec(@cmd);
+ die "$0: Failure to exec(): $!\n";
+}
+else {
+ $SIG{'INT'} = 'IGNORE';
+ $SIG{'QUIT'} = 'IGNORE';
+
+ if (waitpid($pid, 0) == -1) {
+ die "$0: Failure to waitpid(): $!\n";
+ }
+
+ my $exitcode = $? >> 8;
+ my ($sec2, $msec2) = gettimeofday();
+ my (undef, undef, $cuser, $csystem) = times();
+
+ printf STDERR "%s#%.2f#%.2f#%.2f\n",
+ $prefix, $cuser, $csystem,
+ ($sec2 - $sec) + ($msec2 - $msec) / 1000000;
+
+ $SIG{'INT'} = 'DEFAULT';
+ $SIG{'QUIT'} = 'DEFAULT';
+
+ exit $exitcode;
+}