aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-11-14 07:35:11 +0100
committerFelix Fietkau <nbd@nbd.name>2020-11-14 14:48:30 +0100
commitcc16f5d73e770136eb0f3cf92ed518292d626bac (patch)
tree4b38e666227631fc6907f60b0f3d44fc0d064fe6 /include/prereq-build.mk
parentee8ef9b10b3b5eb13f83940ef79cf73f0f18584b (diff)
downloadupstream-cc16f5d73e770136eb0f3cf92ed518292d626bac.tar.gz
upstream-cc16f5d73e770136eb0f3cf92ed518292d626bac.tar.bz2
upstream-cc16f5d73e770136eb0f3cf92ed518292d626bac.zip
build: try to find getopt in macOS homebrew's standard location
It is not symlinked to /usr/local/bin by default Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f67a01299e..8181812599 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -125,7 +125,8 @@ $(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
$(eval $(call SetupHostCommand,getopt, \
Please install an extended getopt version that supports --long, \
gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
- getopt -o t --long test -- --test | grep '^ *--test *--'))
+ getopt -o t --long test -- --test | grep '^ *--test *--', \
+ /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
$(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
gnustat -c%s $(TOPDIR)/Makefile, \