aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2019-11-14 16:41:10 +0100
committerPetr Štetiar <ynezz@true.cz>2019-11-14 22:53:31 +0100
commit2066ee09d99441a67a5f23b6e38baeadc9f92e15 (patch)
treebef082b45beb504c02c8886c8148cb47680f5b4b /include/prereq-build.mk
parentc001ace8bdf03fec036840638a1fa2a1edd8b2b6 (diff)
downloadupstream-2066ee09d99441a67a5f23b6e38baeadc9f92e15.tar.gz
upstream-2066ee09d99441a67a5f23b6e38baeadc9f92e15.tar.bz2
upstream-2066ee09d99441a67a5f23b6e38baeadc9f92e15.zip
build: prereq: add support for Python 3.8
Add support for Python 3.8 which was released Oct. 14, 2019. Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de> [added missing commit description, simplified version check] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d73f0040c3..a711ae33f7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -144,12 +144,14 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+ python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+ python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
python3.5 -V 2>&1 | grep 'Python 3', \