aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-11-14 16:50:18 +0100
committerPetr Štetiar <ynezz@true.cz>2019-11-14 22:53:31 +0100
commitc001ace8bdf03fec036840638a1fa2a1edd8b2b6 (patch)
treecdeb531ffbac216163c6f2d4f1c8148625b4ceab /include/prereq-build.mk
parent953c27df315ded7fae45daba0229ced4309e4baa (diff)
downloadupstream-c001ace8bdf03fec036840638a1fa2a1edd8b2b6.tar.gz
upstream-c001ace8bdf03fec036840638a1fa2a1edd8b2b6.tar.bz2
upstream-c001ace8bdf03fec036840638a1fa2a1edd8b2b6.zip
build: prereq: simplify Python 3 version checks
We don't need to check if python3.5 binary is actually Python 3.5+. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4c59910056..d73f0040c3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -144,15 +144,15 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
- python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.7 -V 2>&1 | grep 'Python 3', \
+ python3.6 -V 2>&1 | grep 'Python 3', \
+ python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
- python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.7 -V 2>&1 | grep 'Python 3', \
+ python3.6 -V 2>&1 | grep 'Python 3', \
+ python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \