aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-15 10:57:03 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:18:06 +0100
commit62d5ec7306f9664aeba64bc64c0dee1d93978bb4 (patch)
tree09597f31a7c33a4236c94aace208e05a4127dd25 /include/package-ipkg.mk
parentfd29f2bcd97f7af7de22ac95b1490a54f45d6c88 (diff)
downloadupstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.tar.gz
upstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.tar.bz2
upstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.zip
build: store SourceDateEpoch in manifest
The usage of granular `SOURCE_DATE_EPOCH` for packages is an incrementing integer which could be useful for downstream tooling, therefore add it to the packages manifest. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 808ac1c6e3..0b7a561edc 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -181,6 +181,7 @@ $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
)$$(call addfield,LicenseFiles,$(LICENSE_FILES)
)$$(call addfield,Section,$(SECTION)
)$$(call addfield,Require-User,$(USERID)
+)$$(call addfield,SourceDateEpoch,$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh $(SOURCE))
)$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
)$(if $(filter hold,$(PKG_FLAGS)),Status: unknown hold not-installed
)$(if $(filter essential,$(PKG_FLAGS)),Essential: yes