aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-15 10:57:02 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:18:06 +0100
commitfd29f2bcd97f7af7de22ac95b1490a54f45d6c88 (patch)
tree705c2cfd9707795fcdb382db69853ec7a12c453d /include/package-ipkg.mk
parenta83b2af47f1796c9bd6d0d49c606391d64538dce (diff)
downloadupstream-fd29f2bcd97f7af7de22ac95b1490a54f45d6c88.tar.gz
upstream-fd29f2bcd97f7af7de22ac95b1490a54f45d6c88.tar.bz2
upstream-fd29f2bcd97f7af7de22ac95b1490a54f45d6c88.zip
build: store granular timestamps in packages
With the new `SOURCE` argument of `get_source_date_epoch` it is possible to set package timestamps based on actual package changes rather thane $TOPDIR changes. This commit adds a new variable PKG_SOURCE_DATE_EPOCH which is used by the `ipkg` build script. As a fallback the existing SOURCE_DATE_EPOCH is used or as last resort the current time. The redundant checks for `.git/` and `.svn/` are removed. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index d8b65433c2..808ac1c6e3 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -192,6 +192,7 @@ $(_endef)
$$(IPKG_$(1)) : export CONTROL=$$(Package/$(1)/CONTROL)
$$(IPKG_$(1)) : export DESCRIPTION=$$(Package/$(1)/description)
$$(IPKG_$(1)) : export PATH=$$(TARGET_PATH_PKG)
+ $$(IPKG_$(1)) : export PKG_SOURCE_DATE_EPOCH=$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh $(SOURCE))
$(PKG_INFO_DIR)/$(1).provides $$(IPKG_$(1)): $(STAMP_BUILT) $(INCLUDE_DIR)/package-ipkg.mk
@rm -rf $$(IDIR_$(1)); \
$$(call remove_ipkg_files,$(1),$$(call opkg_package_files,$(call gen_ipkg_wildcard,$(1))))