aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-06-18 23:27:51 +0200
committerFelix Fietkau <nbd@nbd.name>2017-06-19 20:39:33 +0200
commit3ce60ba0a163636c968c4046894beca0efe1907e (patch)
tree7a028c0e1e2bc456192e541d192bbb2b12f55e7a /include/kernel.mk
parentb5aaafe9a36031149fa52bd07aa4a339e226c23c (diff)
downloadupstream-3ce60ba0a163636c968c4046894beca0efe1907e.tar.gz
upstream-3ce60ba0a163636c968c4046894beca0efe1907e.tar.bz2
upstream-3ce60ba0a163636c968c4046894beca0efe1907e.zip
build: Fix not altering KERNELRELEASE for external kernel
When an external kernel tree is used the version should not get modified by the LEDE build scripts. This was added by Florian some time ago. The commit 0aed054becb21439 ("build: add KERNEL_MAKE and KERNEL_MAKE_FLAGS variables and move to kernel.mk") breaks this feature introduced in b6746a6ffb73 ("include: Do not alter KERNELRELEASE for external/git kernels"). Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 464c94572e..7674f0dadc 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -108,11 +108,10 @@ KERNEL_MAKE_FLAGS := \
CONFIG_SHELL="$(BASH)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
$(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID)) \
- KERNELRELEASE=$(LINUX_VERSION) \
cmd_syscalls=
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
- KERNEL_MAKEOPTS += \
+ KERNEL_MAKE_FLAGS += \
KERNELRELEASE=$(LINUX_VERSION)
endif