aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 15:48:40 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 15:51:18 +0100
commit8416d0626f57ff3303a44a7b9e29f97c3e380e63 (patch)
tree603090ce9f3b1887a75884f0c07cb722912eb001 /include/image-commands.mk
parentff012f3a67eba3622265b2aaf38da6a0a4574021 (diff)
downloadupstream-8416d0626f57ff3303a44a7b9e29f97c3e380e63.tar.gz
upstream-8416d0626f57ff3303a44a7b9e29f97c3e380e63.tar.bz2
upstream-8416d0626f57ff3303a44a7b9e29f97c3e380e63.zip
build: uImage: separate arguments into individual lines
Having one line per argument increases overview dramatically. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index a8faefbcff..de4c86c24a 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -394,11 +394,16 @@ define Build/tplink-v2-image
endef
define Build/uImage
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel \
- -C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ mkimage \
+ -A $(LINUX_KARCH) \
+ -O linux \
+ -T kernel \
+ -C $(word 1,$(1)) \
+ -a $(KERNEL_LOADADDR) \
+ -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
- $(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
+ $(wordlist 2,$(words $(1)),$(1)) \
+ -d $@ $@.new
mv $@.new $@
endef