aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-11-04 10:21:13 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 15:46:34 +0100
commitff012f3a67eba3622265b2aaf38da6a0a4574021 (patch)
tree6e8b6ace3a8fb1cfac4354fd73bab4a91d6af31c /include/image-commands.mk
parent4a243ae3329c19eaddffea42bed734e4eff852ad (diff)
downloadupstream-ff012f3a67eba3622265b2aaf38da6a0a4574021.tar.gz
upstream-ff012f3a67eba3622265b2aaf38da6a0a4574021.tar.bz2
upstream-ff012f3a67eba3622265b2aaf38da6a0a4574021.zip
build: uImage: allow override of default arguments
For some build recipes, the argument to Build/uImage is used to sneak in extra arguments for mkimage, whereas this appears to have been intended to specificy the compression method only. Use the first provided word for -C to be backwards compatible with current calls to Build/uImage. Use the rest of the call arguments to override the provided defaults. Only the input file name (-d) and the output file name cannot overriden. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 438f1e87e4..a8faefbcff 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -396,8 +396,9 @@ endef
define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
- -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
+ -C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
+ $(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
mv $@.new $@
endef