aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 13:38:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 13:38:34 +0000
commit74ca7e9af3b7b0cae395c07c4a50fb903709619b (patch)
treeb92f0e748110b1c732f34c91e9696cf2a4282bfa /Makefile
parent693e5aae4160a69958b64fed77daa1696392fb0b (diff)
downloadupstream-74ca7e9af3b7b0cae395c07c4a50fb903709619b.tar.gz
upstream-74ca7e9af3b7b0cae395c07c4a50fb903709619b.tar.bz2
upstream-74ca7e9af3b7b0cae395c07c4a50fb903709619b.zip
build: clean up sitefiles, make them per-arch
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45090
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 91b6946ac3..2b08d30ffe 100644
--- a/Makefile
+++ b/Makefile
@@ -75,10 +75,10 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
- @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
- echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+ echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
echo ' The missing file will cause configure scripts to fail during compilation.'; \
- echo ' Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
exit 1; \
fi