aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-07 11:53:18 +0000
committerMike Baker <mbm@openwrt.org>2007-04-07 11:53:18 +0000
commit1ad09590cc241424747be81de3e0a9ae5cbb074b (patch)
tree3b410dcdf7087ac387e5ff52ee736058afdfa7ad /Makefile
parent5305aba54930edb219ac2111811134a16e28978e (diff)
downloadupstream-1ad09590cc241424747be81de3e0a9ae5cbb074b.tar.gz
upstream-1ad09590cc241424747be81de3e0a9ae5cbb074b.tar.bz2
upstream-1ad09590cc241424747be81de3e0a9ae5cbb074b.zip
same as [6881]
SVN-Revision: 6882
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index d7e4585595..cab2486fb1 100644
--- a/Makefile
+++ b/Makefile
@@ -62,10 +62,10 @@ tmp/.config-%.in: tmp/.%info
.config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
- @[ -f .config ] || { \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
$(NO_TRACE_MAKE) menuconfig; \
- }
+ fi
@$< -D .config Config.in &> /dev/null
scripts/config/mconf: