aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-07 11:03:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-07 11:03:05 +0000
commit5305aba54930edb219ac2111811134a16e28978e (patch)
treed236c64df56a270968499dbd6d85afc0cdca1cc5 /Makefile
parent74c927577d0c7aac96fe8f034913423b4be56a0d (diff)
downloadupstream-5305aba54930edb219ac2111811134a16e28978e.tar.gz
upstream-5305aba54930edb219ac2111811134a16e28978e.tar.bz2
upstream-5305aba54930edb219ac2111811134a16e28978e.zip
fix menuconfig
SVN-Revision: 6881
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index fffc3bf5da..d7e4585595 100644
--- a/Makefile
+++ b/Makefile
@@ -90,9 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
$< -o Config.in
menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
- @[ -f .config ] || { \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
- }
+ @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
+ fi
$< Config.in
kernel_menuconfig: .config FORCE