aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 888c1c5a9b..705d409ac5 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -42,8 +42,16 @@ define Device/Default
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef
+ifeq ($(SUBTARGET),cortexa7)
include cortex-a7.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa8)
include cortex-a8.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
$(eval $(call BuildImage))